Bug 1472153 - Rebase PCP for RHEL 7.5
Summary: Rebase PCP for RHEL 7.5
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pcp (Show other bugs)
(Show other bugs)
Version: 7.5
Hardware: All Linux
medium
medium
Target Milestone: alpha
: ---
Assignee: pcp-maint
QA Contact: Michal Kolar
Marek Suchanek
URL:
Whiteboard:
Keywords: Rebase
: 1366924 (view as bug list)
Depends On:
Blocks: 1420851 1471969 1477664 1477926 1420926 1430070 1457956 1483557 1487850 1496177 1525864
TreeView+ depends on / blocked
 
Reported: 2017-07-18 07:59 UTC by Nathan Scott
Modified: 2018-04-10 17:07 UTC (History)
14 users (show)

Fixed In Version: pcp-3.12.2-1.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
_pcp_ rebased to version 3.12.2 The Performance Co-Pilot (PCP) application has been rebased to version 3.12.2, which includes many enhancements and bug fixes. Collector systems updates: * The following Performance Metric Domain Agents (PMDAs) have been updated: `perfevent`, containers and CGroups, MySQL slave metrics, Linux per-process metrics, and Linux kernel metrics for entropy, `slabinfo`, IPv6 sockets, and NFSD worker threads. * New PMDAs are now available: Prometheus endpoint and HAProxy. * Device Mapper statistics now expose an API. Monitor systems updates: * The derived metrics language has been extended for all monitors. * The `pmchart` charting utility includes fixes for timezone and display bugs. * The `pmlogconf` configuration utility automatically enables the `hotproc` metric logging and adds `atop` metrics. Performance is now more optimized. * The `pcp-atop` monitoring utility recognizes the new "--hotproc" option. Several bugs have been fixed. * The `pcp-pidstat` and `pcp-mpstat` monitoring utilities recognize several new output options. * The `pmrep` reporting utility now supports Comma-separated Values (CSV) output compatible with the `sadf` tool. New utilities for exporting PCP metrics to various formats have also been added: `pcp2zabbix`, `pcp2xml`, `pcp2json`, and `pcp2elasticsearch`.
Story Points: ---
Clone Of:
: 1496177 (view as bug list)
Environment:
Last Closed: 2018-04-10 17:06:22 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0926 None None None 2018-04-10 17:07 UTC
Red Hat Bugzilla 1391695 None None None Never
Red Hat Bugzilla 1415816 None None None Never

Description Nathan Scott 2017-07-18 07:59:22 UTC
We'd like to rebase PCP for RHEL 7.5 to pick up the next round of enhancements and fixes, incl. several of both for customers.

Some of these that are complete and/or already in-progress include HAProxy instrumentation, Prometheus endpoint metrics, new Device Mapper statistis, and new container and NUMA analysis tools.

Comment 5 Chris Williams 2017-10-10 21:37:23 UTC
*** Bug 1366924 has been marked as a duplicate of this bug. ***

Comment 14 Lukas Berk 2018-01-07 17:14:40 UTC
Looks good to me Marek.

Comment 15 Michal Kolar 2018-02-26 14:38:30 UTC
Verified against pcp-3.12.2-5.el7

Comment 19 errata-xmlrpc 2018-04-10 17:06:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0926


Note You need to log in before you can comment on or make changes to this bug.