Bug 1472188 - pam_usb: package missing default config file
pam_usb: package missing default config file
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pam_usb (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Francisco Javier Tsao Santín
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-18 04:56 EDT by Vasiliy Glazov
Modified: 2017-07-18 06:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-18 06:38:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vasiliy Glazov 2017-07-18 04:56:41 EDT
Description of problem:
This package not contain default config file /etc/pamusb.conf

Version-Release number of selected component (if applicable):
pam_usb-0.5.0-2


$ sudo pamusb-conf --add-device sample
Please select the device you wish to add.
* Using "ADATA USB Flash Drive (00000003AABBFA)" (only option)

Which volume would you like to use for storing data ?
* Using "/dev/sdg1 (UUID: ECF0-6724)" (only option)

Name            : sample
Vendor          : ADATA
Model           : USB Flash Drive
Serial          : 00000003AABBFA
UUID            : ECF0-6724

Save to /etc/pamusb.conf ?
[Y/n] y
Unable to read /etc/pamusb.conf: [Errno 2] No such file or directory: '/etc/pamusb.conf'


Even after touch /etc/pamusb.conf it can't be used:

Save to /etc/pamusb.conf ?
[Y/n] y
Unable to read /etc/pamusb.conf: no element found: line 1, column 0

Adding sample file from git repo solving problem.
Comment 1 Francisco Javier Tsao Santín 2017-07-18 06:14:51 EDT
The default config file is in /etc/security/pamusb.conf. I moved there because I think is more appropiate to be there with other pam configs.
Comment 2 Vasiliy Glazov 2017-07-18 06:38:46 EDT
OK, I did not see it first.

But pamusb-conf use /etc/pamusb.conf by default. I am think it need to be cleared (moved back or simlinked) so users did not fall into this situation.
Comment 3 Francisco Javier Tsao Santín 2017-07-18 06:54:50 EDT
That's right. I'll issue a patch.

Note You need to log in before you can comment on or make changes to this bug.