Bug 1472190 - [SAMBA-VSS]Previous version restore link is not visible over windows mount even after taking a snapshot
[SAMBA-VSS]Previous version restore link is not visible over windows mount ev...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba (Show other bugs)
3.2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: RHGS 3.2.0 Async
Assigned To: Anoop C S
Vivek Das
: Regression, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-18 04:57 EDT by Vivek Das
Modified: 2017-08-01 03:46 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.8.4-18.6
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 03:46:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vivek Das 2017-07-18 04:57:37 EDT
Description of problem:
With all the VSS plugins take a snapshot and activate it. Change data over windows mount and do a right click to check previous version, but no link is available.

Version-Release number of selected component (if applicable):
RHEL7.4
samba-4.6.3-4.el7rhgs.x86_64
glusterfs-server-3.8.4-18.5.el7rhgs.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Enable USS
2.Enable VSS plugins
3.Take a snapshot and activate it
4.Over the windows mount change data
5.Right click and check for the restore the link

Actual results:
Restore link is not seen

Expected results:
Restore link should be available

Additional info:
Comment 4 Atin Mukherjee 2017-07-19 05:48:36 EDT
downstream patch : https://code.engineering.redhat.com/gerrit/#/c/112758/
Comment 6 Vivek Das 2017-07-24 01:38:34 EDT
With the latest version glusterfs-3.8.4-18.6 i am able to restore data in windows mount post taking a snapshot.
Marking this as verified.
Comment 8 errata-xmlrpc 2017-08-01 03:46:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2339

Note You need to log in before you can comment on or make changes to this bug.