Bug 1472222 - Incorrect address of kibana route configured when logging stacks is installed within the process of OCP installation
Incorrect address of kibana route configured when logging stacks is installed...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: ewolinet
Xia Zhao
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-18 05:30 EDT by Xia Zhao
Modified: 2017-08-16 15 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-10 01:31:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The inventory file used for logging deployment where a correct kibana route address is got (744 bytes, text/plain)
2017-07-19 02:22 EDT, Xia Zhao
no flags Details

  None (edit)
Description Xia Zhao 2017-07-18 05:30:50 EDT
Description of problem:
Install logging stacks along with OCP by specifying these lines in inventory:
  openshift_hosted_logging_deploy=true
  openshift_hosted_logging_storage_kind=nfs
  openshift_hosted_logging_storage_access_modes=['ReadWriteOnce']
  openshift_hosted_logging_storage_nfs_directory=/var/lib/exports
  openshift_hosted_logging_storage_nfs_options='"*(rw,root_squash)"'
  openshift_hosted_logging_storage_volume_name=logging
  openshift_hosted_logging_storage_volume_size=10G
  openshift_hosted_logging_deployer_prefix=${brew-registry}/openshift3/
  openshift_hosted_logging_deployer_version=v3.6

The kibana route address is configured to be:
# oc get route
NAME             HOST/PORT                                 PATH      SERVICES         PORT      TERMINATION          WILDCARD
logging-kibana   kibana.router.default.svc.cluster.local             logging-kibana   <all>     reencrypt/Redirect   None

It should be $subdomain in master-config file of openshift cluster, otherwise can't be recognized by openshift router.

Version-Release number of selected component (if applicable):
# openshift version
openshift v3.6.152.0
kubernetes v1.6.1+5115d708d7
etcd 3.2.1

# rpm -qa | grep ansible
openshift-ansible-filter-plugins-3.6.152.0-1.git.0.e58be7d.el7.noarch
openshift-ansible-docs-3.6.152.0-1.git.0.e58be7d.el7.noarch
openshift-ansible-lookup-plugins-3.6.152.0-1.git.0.e58be7d.el7.noarch
openshift-ansible-callback-plugins-3.6.152.0-1.git.0.e58be7d.el7.noarch
openshift-ansible-playbooks-3.6.152.0-1.git.0.e58be7d.el7.noarch
ansible-2.2.3.0-1.el7.noarch
openshift-ansible-3.6.152.0-1.git.0.e58be7d.el7.noarch
openshift-ansible-roles-3.6.152.0-1.git.0.e58be7d.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1.Install logging stacks v3.6 along with OCP 3.6 cluster's installation
2.Check the address of kibana route after EFK is running
3.

Actual results:
# oc get route
NAME             HOST/PORT                                 PATH      SERVICES         PORT      TERMINATION          WILDCARD
logging-kibana   kibana.router.default.svc.cluster.local             logging-kibana   <all>     reencrypt/Redirect   None

Expected results:
It should be $subdomain in master-config file of openshift cluster, otherwise can't be recognized by openshift router.

Additional info:
1. Issue did not repro when logging stacks were installed seperately post openshift's installation by running this command:
$ ansible-playbook -i ~/inventory -v /usr/share/ansible/openshift-ansible/playbooks/byo/openshift-cluster/openshift-logging.yml
2. Full log of openshift installation / inventory file were provided in comment #1
Comment 2 Xia Zhao 2017-07-18 05:32:57 EDT
The test env in comment #1 were redeployed, env is no longer in the state when bug repro.
Comment 3 ewolinet 2017-07-18 11:35:23 EDT
Xia,

What does the correctly created route look like?
Can you provide the output of oc get route for that?
Comment 5 Xia Zhao 2017-07-19 02:22 EDT
Created attachment 1300829 [details]
The inventory file used for logging deployment where a correct kibana route address is got
Comment 8 Xia Zhao 2017-07-19 23:00:24 EDT
Thanks for your effort here, Eric. Please always feel free to let me know if anything else I can do from QE side to ease your work here.
Comment 9 Scott Dodson 2017-07-20 10:05:23 EDT
We can't re-create this issue can QE please reset.
Comment 13 Xia Zhao 2017-07-24 22:57:00 EDT
Thanks for the fix, Eric. My auto installed logging environment is back today, the address of kibana route was configured to ${subdomain} there, and logging system working fine. Set to verified.

The ansible version tested with:
openshift-ansible-playbooks-3.6.169-1.git.0.440d532.el7.noarch

# openshift version
openshift v3.6.169
kubernetes v1.6.1+5115d708d7
etcd 3.2.1
Comment 15 errata-xmlrpc 2017-08-10 01:31:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1716

Note You need to log in before you can comment on or make changes to this bug.