Bug 1472244 - Installation failed when building env behind proxy
Installation failed when building env behind proxy
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Tim Bielawa
Gaoyun Pei
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-18 05:56 EDT by Gaoyun Pei
Modified: 2017-08-16 15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: A fix for a separate PROXY related issue was merged Consequence: Various proxy related operations began to fail Fix: A correct fix for the original PROXY related issue was merged Result: Functionality restored
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-10 01:31:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gaoyun Pei 2017-07-18 05:56:06 EDT
Description of problem:
Installation failed when building env behind proxy on openstack

Version-Release number of the following components:
openshift-ansible-3.6.153-1.git.0.5a6bf7d.el7.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1.Set the following options in ansible inventory to build env using proxy
openshift_http_proxy=http://proxy.x.com:x
openshift_https_proxy=http://proxy.x.com:x
openshift_no_proxy="169.254.169.254"

2.Start installer

Actual results:
TASK [openshift_facts : Gather Cluster facts and set is_containerized if needed] ***
Tuesday 18 July 2017  08:55:48 +0000 (0:00:00.086)       0:00:28.929 ********** 
An exception occurred during task execution. To see the full traceback, use -vvv. The error was: KeyError: 'no_proxy_internal_hostnames'
fatal: [openshift-x.com]: FAILED! => {
    "changed": false, 
    "failed": true, 
    "module_stderr": "Traceback (most recent call last):\n  File \"/tmp/ansible_7JbNKe/ansible_module_openshift_facts.py\", line 2601, in <module>\n    main()\n  File \"/tmp/ansible_7JbNKe/ansible_module_openshift_facts.py\", line 2588, in main\n    protected_facts_to_overwrite)\n  File \"/tmp/ansible_7JbNKe/ansible_module_openshift_facts.py\", line 1992, in __init__\n    protected_facts_to_overwrite)\n  File \"/tmp/ansible_7JbNKe/ansible_module_openshift_facts.py\", line 2058, in generate_facts\n    facts = set_proxy_facts(facts)\n  File \"/tmp/ansible_7JbNKe/ansible_module_openshift_facts.py\", line 1673, in set_proxy_facts\n    auto_hosts = common['no_proxy_internal_hostnames'].split(',')\nKeyError: 'no_proxy_internal_hostnames'\n", 
    "module_stdout": ""
}

MSG:

MODULE FAILURE

        to retry, use: --limit @/home/slave5/workspace/Launch-Environment-Flexy/private-openshift-ansible/playbooks/byo/config.retry


Expected results:


Additional info:
Comment 1 Gaoyun Pei 2017-07-18 06:06:49 EDT
This bug blocks testing on ocp-3.6 cluster with proxy used
Comment 4 Gaoyun Pei 2017-07-24 03:30:29 EDT
Verify this bug with openshift-ansible-3.6.167-1.git.0.0ce5583.el7.noarch.rpm

ocp-3.6 installation with global proxy configured was successful.
Comment 6 errata-xmlrpc 2017-08-10 01:31:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1716

Note You need to log in before you can comment on or make changes to this bug.