Bug 1472250 - Remove fop_enum_to_string, get_fop_int usage in libglusterfs
Remove fop_enum_to_string, get_fop_int usage in libglusterfs
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-18 06:05 EDT by Pranith Kumar K
Modified: 2017-09-05 13:37 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.12.0
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-05 13:37:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2017-07-18 06:05:19 EDT
Description of problem:
Implementation of these two functions becomes easier by using gf_fop_list[] array. So will implement that and remove usage of these functions.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Worker Ant 2017-07-18 06:09:08 EDT
REVIEW: https://review.gluster.org/17812 (common-utils: Remove fop_enum_to_string, get_fop_int) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Worker Ant 2017-07-18 06:10:34 EDT
REVIEW: https://review.gluster.org/17812 (common-utils: Remove fop_enum_to_string, get_fop_int) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 3 Worker Ant 2017-07-18 07:34:30 EDT
REVIEW: https://review.gluster.org/17812 (common-utils: Remove fop_enum_to_string, get_fop_int) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 4 Worker Ant 2017-07-18 13:10:35 EDT
COMMIT: https://review.gluster.org/17812 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 63d46236592c9e3c2fef05fd60d1c39548e57a8d
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Tue Jul 18 15:23:12 2017 +0530

    common-utils: Remove fop_enum_to_string, get_fop_int
    
    Implementation of these two functions becomes easier by using gf_fop_list[]
    array. So implemented that and removed usage of these functions.
    
    BUG: 1472250
    Change-Id: I8a592913f9eeb02d965708bcf28a637588ed4988
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: https://review.gluster.org/17812
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
Comment 5 Shyamsundar 2017-09-05 13:37:29 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.12.0, please open a new bug report.

glusterfs-3.12.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-September/000082.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.