Bug 1472272 - Rebase libguestfs to current upstream release
Rebase libguestfs to current upstream release
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs (Show other bugs)
7.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Pino Toscano
Virtualization Bugs
Jiri Herrmann
: Rebase
Depends On:
Blocks: 1417306 1450325 1466563 1469590 1472288 1472719 1482737 1494555
  Show dependency treegraph
 
Reported: 2017-07-18 06:40 EDT by Jaroslav Suchanek
Modified: 2018-04-10 05:15 EDT (History)
7 users (show)

See Also:
Fixed In Version: libguestfs-1.36.10-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 05:15:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Suchanek 2017-07-18 06:40:20 EDT
Description of problem:

libguestfs upstream maintains a very strong commitment to backwards
compatibility.  We have never broken the C API, and (apart from
one notorious occasion with virt-inspector that happened a long
time ago) never break backwards compat for command line tools either.

Therefore it makes sense to rebase libguestfs in RHEL 7.5.

Version-Release number of selected component (if applicable):

Current upstream version of libguestfs.
Comment 5 Jaroslav Suchanek 2017-12-11 08:14:00 EST
Pino, can please share news for release notes? Thanks.
Comment 6 Pino Toscano 2018-01-23 12:32:42 EST
Except from internal code refactoring, and small bugfixes already documented in other bugs (or not worth being documented), the rebase does not contain anything else notable.
Comment 10 errata-xmlrpc 2018-04-10 05:15:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0677

Note You need to log in before you can comment on or make changes to this bug.