Bug 1472425 - Java exception in slave25.cloud.gluster.org while fetching source
Java exception in slave25.cloud.gluster.org while fetching source
Status: CLOSED WORKSFORME
Product: GlusterFS
Classification: Community
Component: project-infrastructure (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-18 13:02 EDT by Kotresh HR
Modified: 2017-07-19 03:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-19 03:31:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kotresh HR 2017-07-18 13:02:21 EDT
Description of problem:
Centos Regression could not be started because of following exception
11:04:03 java.io.EOFException
11:04:03 	at java.io.ObjectInputStream$PeekInputStream.readFully(ObjectInputStream.java:2638)
11:04:03 	at java.io.ObjectInputStream$BlockDataInputStream.readShort(ObjectInputStream.java:3113)
11:04:03 	at java.io.ObjectInputStream.readStreamHeader(ObjectInputStream.java:853)
11:04:03 	at java.io.ObjectInputStream.<init>(ObjectInputStream.java:349)
11:04:03 	at hudson.remoting.ObjectInputStreamEx.<init>(ObjectInputStreamEx.java:48)
11:04:03 	at hudson.remoting.AbstractSynchronousByteArrayCommandTransport.read(AbstractSynchronousByteArrayCommandTransport.java:34)
11:04:03 	at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:59)
11:04:03 Caused: java.io.IOException: Unexpected termination of the channel
11:04:03 	at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:73)
11:04:03 Caused: hudson.remoting.RequestAbortedException
11:04:03 	at hudson.remoting.Request.abort(Request.java:307)
11:04:03 	at hudson.remoting.Channel.terminate(Channel.java:896)
11:04:03 	at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:92)
11:04:03 	at ......remote call to slave25.cloud.gluster.org(Native Method)
11:04:03 	at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1545)
11:04:03 	at hudson.remoting.Request.call(Request.java:172)
11:04:03 	at hudson.remoting.Channel.call(Channel.java:829)
11:04:03 	at org.jenkinsci.plugins.gitclient.RemoteGitImpl$CommandInvocationHandler.execute(RemoteGitImpl.java:146)
11:04:03 	at sun.reflect.GeneratedMethodAccessor285.invoke(Unknown Source)
11:04:03 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
11:04:03 	at java.lang.reflect.Method.invoke(Method.java:498)
11:04:03 	at org.jenkinsci.plugins.gitclient.RemoteGitImpl$CommandInvocationHandler.invoke(RemoteGitImpl.java:132)
11:04:03 	at com.sun.proxy.$Proxy68.execute(Unknown Source)
11:04:03 	at hudson.plugins.git.GitSCM.fetchFrom(GitSCM.java:810)
11:04:03 	at hudson.plugins.git.GitSCM.retrieveChanges(GitSCM.java:1079)
11:04:03 	at hudson.plugins.git.GitSCM.checkout(GitSCM.java:1110)
11:04:03 	at hudson.scm.SCM.checkout(SCM.java:495)
11:04:03 	at hudson.model.AbstractProject.checkout(AbstractProject.java:1276)
11:04:03 	at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:560)
11:04:03 	at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
11:04:03 	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:485)
11:04:03 	at hudson.model.Run.execute(Run.java:1735)
11:04:03 	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
11:04:03 	at hudson.model.ResourceController.execute(ResourceController.java:97)
11:04:03 	at hudson.model.Executor.run(Executor.java:405)


Version-Release number of selected component (if applicable):


How reproducible:
Once

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Nigel Babu 2017-07-19 03:31:21 EDT
This looks like a temporary problem that happened just about then. Mostly a network issue. This seems to be fixed now. I see other jobs passing.

Note You need to log in before you can comment on or make changes to this bug.