Bug 1472446 - packaging: save ganesha config files in (/var)/run/gluster/shared_storage/nfs-ganesha
packaging: save ganesha config files in (/var)/run/gluster/shared_storage/nfs...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: packaging (Show other bugs)
3.10
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kaleb KEITHLEY
: Triaged
Depends On: 1472445
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-18 14:31 EDT by Kaleb KEITHLEY
Modified: 2017-08-21 09:41 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.10.5
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1472445
Environment:
Last Closed: 2017-08-21 09:41:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaleb KEITHLEY 2017-07-18 14:31:30 EDT
+++ This bug was initially created as a clone of Bug #1472445 +++

Description of problem:

ganesha config files in (/var)/run/gluster/shared_storage/nfs-ganesha need to be marked with %config(noreplace) in the glusterfs-ganesha subpackage.

They probably need to be "ghosted" (with %ghost) too

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Red Hat Bugzilla Rules Engine on 2017-07-18 14:29:17 EDT ---

This bug is automatically being proposed for the current release of Red Hat Gluster Storage 3 under active development, by setting the release flag 'rhgs‑3.3.0' to '?'. 

If this bug should be proposed for a different release, please manually change the proposed release flag.
Comment 1 Worker Ant 2017-07-26 11:16:47 EDT
REVIEW: https://review.gluster.org/17883 (packaging: own files in (/var)/run/gluster/shared_storage/nfs-ganesha) posted (#1) for review on release-3.10 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 2 Worker Ant 2017-07-28 08:29:02 EDT
COMMIT: https://review.gluster.org/17883 committed in release-3.10 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 5eed664c6c243c261506743448d99a80979942f2
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Wed Jul 26 10:36:11 2017 -0400

    packaging: own files in (/var)/run/gluster/shared_storage/nfs-ganesha
    
    The nfs-ganesha rpm owns /etc/ganesha and /etc/ganesha/ganesha.conf,
    but gluster-ganesha installs a ganesha-ha.conf.sample in /etc/ganesha/
    
    Ganesha HA expects to find the config files in /var/run/.../nfs-ganesha
    and for there to be symlinks from /etc/ganesha/* to /var/run/...
    
    As exports are created the ganesha export files are written to
    /var/run/gluster/shared_storage/nfs-ganesha/exports/*
    
    This change creates rpm %ghosts for most of these files to manage
    ownership within rpm and ensure they are not deleted or overwritten
    during package install/upgrade/removal. The name of the exports varies,
    so it's not possible AFAIK to create wildcard %ghosts for them.
    
    Change-Id: Ic4389291c0af0bd72c22fa742cdfa2011b9286f3
    BUG: 1472446
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: https://review.gluster.org/17883
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
Comment 3 Shyamsundar 2017-08-21 09:41:22 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.5, please open a new bug report.

glusterfs-3.10.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-August/000079.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.