Bug 1472467 - Ansible Service Broker: Update openshift-ansible install to reference new broker image name, ose-ansible-service-broker
Ansible Service Broker: Update openshift-ansible install to reference new br...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fabian von Feilitzsch
Johnny Liu
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-18 15:59 EDT by John Matthews
Modified: 2017-08-16 15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-10 01:31:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Matthews 2017-07-18 15:59:36 EDT
Description of problem:

Prior to 3.6.0 release we want to conform to OpenShift conventions of adding "ose-" prefix to openshift components.

A small change will be required to the installer to ensure the proper image is used.
Comment 3 Johnny Liu 2017-07-28 02:05:06 EDT
Verified this bug with openshift-ansible-3.6.170.1-1.git.0.68f7798.el7.noarch, and PASS.

# oc get po -n openshift-ansible-service-broker
NAME                    READY     STATUS             RESTARTS   AGE
asb-1001951353-9jwtv    0/1       ImagePullBackOff   0          4m
etcd-1487946270-tpwl6   1/1       Running            0          4m


# oc describe po asb-1001951353-9jwtv -n openshift-ansible-service-broker
<--snip-->
Events:
  FirstSeen	LastSeen	Count	From								SubObjectPath		Type		Reason		Message
  ---------	--------	-----	----								-------------		--------	------		-------
  4m		4m		1	default-scheduler									Normal		Scheduled	Successfully assigned asb-1001951353-9jwtv to host-8-174-244.host.centralci.eng.rdu2.redhat.com
  4m		4m		2	kubelet, host-8-174-244.host.centralci.eng.rdu2.redhat.com				Warning		FailedMount	MountVolume.SetUp failed for volume "kubernetes.io/configmap/370cb209-7359-11e7-acab-fa163e6f1f0e-config-volume" (spec.Name: "config-volume") pod "370cb209-7359-11e7-acab-fa163e6f1f0e" (UID: "370cb209-7359-11e7-acab-fa163e6f1f0e") with: configmaps "broker-config" not found
  4m		2m		5	kubelet, host-8-174-244.host.centralci.eng.rdu2.redhat.com	spec.containers{asb}	Normal		BackOff		Back-off pulling image "registry.access.redhat.com/openshift3/ose-ansible-service-broker:latest"
  4m		2m		4	kubelet, host-8-174-244.host.centralci.eng.rdu2.redhat.com	spec.containers{asb}	Normal		Pulling		pulling image "registry.access.redhat.com/openshift3/ose-ansible-service-broker:latest"
  4m		2m		4	kubelet, host-8-174-244.host.centralci.eng.rdu2.redhat.com	spec.containers{asb}	Warning		Failed		Failed to pull image "registry.access.redhat.com/openshift3/ose-ansible-service-broker:latest": rpc error: code = 2 desc = unknown: Not Found
  4m		2m		10	kubelet, host-8-174-244.host.centralci.eng.rdu2.redhat.com				Warning		FailedSync	Error syncing pod


Because the 3.6 is not shipped yet, so the above failure is an expected behavior, also could see that it is pulling image openshift3/ose-ansible-service-broker:latest.
Comment 5 errata-xmlrpc 2017-08-10 01:31:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1716

Note You need to log in before you can comment on or make changes to this bug.