Bug 1472494 - jna no longer provides osgi(com.sun.jna)
jna no longer provides osgi(com.sun.jna)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: jna (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
:
Depends On:
Blocks: HostAndPlatform
  Show dependency treegraph
 
Reported: 2017-07-18 19:09 EDT by Troy Dawson
Modified: 2017-07-19 10:50 EDT (History)
6 users (show)

See Also:
Fixed In Version: 4.4.0-5
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-19 10:50:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Troy Dawson 2017-07-18 19:09:08 EDT
Description of problem:
jna-4.4.0-4 no longer provides  osgi(com.sun.jna).  this is problem because jna-contrib requires it.

Version-Release number of selected component (if applicable):
jna-4.4.0-4.fc27

How reproducible:
100%

Steps to Reproduce:
1.dnf install jna-contrib
2.
3.

Actual results:
Last metadata expiration check: 0:00:30 ago on Tue 18 Jul 2017 06:01:47 PM CDT.
Error: 
 Problem: conflicting requests
  - nothing provides osgi(com.sun.jna) needed by jna-contrib-4.4.0-4.fc27.noarch

Expected results:
Installing:
 jna-contrib noarch 4.4.0-4.fc26
Installing dependencies:
 jna         x86_64 4.4.0-4.fc26

Additional info:
You can see the difference in the provdes by looking at the info pages for the builds.
jna-4.4.0-4.fc27 (not working)
https://koji.fedoraproject.org/koji/rpminfo?rpmID=10178780
jna-4.4.0-2.fc27 (working)
https://koji.fedoraproject.org/koji/rpminfo?rpmID=10092224
Comment 1 Igor Gnatenko 2017-07-18 19:13:29 EDT
Just to clarify that -3 was not broken, but -4 appeared to be..

https://src.fedoraproject.org/cgit/rpms/jna.git/tree/0005-Fix-duplicate-manifest-entry.patch?id=288c87db8d3a08b71e9d2ae286f15eaf6c40e068

This patch broke it.
Comment 2 Troy Dawson 2017-07-18 19:19:21 EDT
I think this stems from the META-INF/MANIFEST.MF differences between the two jna jar files.

4.4.0-2.fc27 (which works) is full of metadata goodness.
(In fact too full, because there are two instances of the file in the jar file)

Manifest-Version: 1.0
Ant-Version: Apache Ant 1.10.1
Created-By: 1.8.0_131-b12 (Oracle Corporation)
Main-Class: com.sun.jna.Native
Implementation-Title: com.sun.jna
Implementation-Vendor: JNA Development Team
Implementation-Version: 4.4.0-SNAPSHOT (b0)
Specification-Title: Java Native Access (JNA)
Specification-Vendor: JNA Development Team
Specification-Version: 4
Bundle-Category: jni
Bundle-ManifestVersion: 2
Bundle-Name: jna
Bundle-Description: JNA Library
Bundle-SymbolicName: com.sun.jna
Bundle-Version: 4.4.0
Bundle-RequiredExecutionEnvironment: J2SE-1.4
Bundle-Vendor: JNA Development Team
Bundle-ActivationPolicy: lazy
Export-Package: com.sun.jna,com.sun.jna.ptr,com.sun.jna.win32
Bundle-NativeCode:  com/sun/jna/win32-x86/jnidispatch.dll; processor=x
 86;osname=win32, com/sun/jna/win32-x86-64/jnidispatch.dll; processor=
 x86-64;osname=win32, com/sun/jna/win32-x86/jnidispatch.dll; processor
 =x86;osname=win, com/sun/jna/win32-x86-64/jnidispatch.dll; processor=
 x86-64;osname=win, com/sun/jna/w32ce-arm/jnidispatch.dll; processor=a
 rm;osname=wince,  com/sun/jna/sunos-x86/libjnidispatch.so; processor=
 x86;osname=sunos, com/sun/jna/sunos-x86-64/libjnidispatch.so; process
 or=x86-64;osname=sunos, com/sun/jna/sunos-sparc/libjnidispatch.so; pr
 ocessor=sparc;osname=sunos, com/sun/jna/sunos-sparcv9/libjnidispatch.
 so; processor=sparcv9;osname=sunos,  com/sun/jna/aix-ppc/libjnidispat
 ch.a; processor=ppc;osname=aix, com/sun/jna/aix-ppc64/libjnidispatch.
 a; processor=ppc64;osname=aix,  com/sun/jna/linux-ppc/libjnidispatch.
 so; processor=ppc;osname=linux, com/sun/jna/linux-ppc64/libjnidispatc
 h.so; processor=ppc64;osname=linux, com/sun/jna/linux-ppc64le/libjnid
 ispatch.so; processor=ppc64le;osname=linux, com/sun/jna/linux-x86/lib
 jnidispatch.so; processor=x86;osname=linux, com/sun/jna/linux-x86-64/
 libjnidispatch.so; processor=x86-64;osname=linux, com/sun/jna/linux-a
 rm/libjnidispatch.so; processor=arm;osname=linux, com/sun/jna/linux-a
 rmel/libjnidispatch.so; processor=armel;osname=linux, com/sun/jna/lin
 ux-aarch64/libjnidispatch.so; processor=aarch64;osname=linux, com/sun
 /jna/linux-ia64/libjnidispatch.so; processor=ia64;osname=linux, com/s
 un/jna/linux-sparcv9/libjnidispatch.so; processor=sparcv9;osname=linu
 x,  com/sun/jna/freebsd-x86/libjnidispatch.so; processor=x86;osname=f
 reebsd, com/sun/jna/freebsd-x86-64/libjnidispatch.so; processor=x86-6
 4;osname=freebsd, com/sun/jna/openbsd-x86/libjnidispatch.so; processo
 r=x86;osname=openbsd, com/sun/jna/openbsd-x86-64/libjnidispatch.so; p
 rocessor=x86-64;osname=openbsd,  com/sun/jna/darwin/libjnidispatch.jn
 ilib; osname=macosx;processor=x86;processor=x86-64;processor=ppc 


4.4.0-4 (which isn't working) only has the following
Manifest-Version: 1.0
Ant-Version: Apache Ant 1.10.1
JavaPackages-Version: 4.4.0-SNAPSHOT
JavaPackages-ArtifactId: jna
JavaPackages-GroupId: net.java.dev.jna
Created-By: 1.8.0_131-b12 (Oracle Corporation)
Comment 3 Mikolaj Izdebski 2017-07-19 08:43:32 EDT
Fixed in jna-4.4.0-5
Comment 4 Mikolaj Izdebski 2017-07-19 10:50:18 EDT
I believe that this bug is fixed in jna-4.4.0-5,
which is available in Fedora Rawhide, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=920338

Note You need to log in before you can comment on or make changes to this bug.