Bug 1472497 - nfs-utils still BuildRequires: fedfs-utils-devel
nfs-utils still BuildRequires: fedfs-utils-devel
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: HostAndPlatform
  Show dependency treegraph
 
Reported: 2017-07-18 19:33 EDT by Troy Dawson
Modified: 2017-07-19 09:56 EDT (History)
5 users (show)

See Also:
Fixed In Version: nfs-utils-2.1.1-6.rc4.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-19 09:56:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Troy Dawson 2017-07-18 19:33:09 EDT
Description of problem:
nfs-utils still BuildRequires: fedfs-utils-devel, yet it builds just fine without it.
Would functionality be lost if we removed that build dependency?

Version-Release number of selected component (if applicable):
nfs-utils-2.1.1-5.rc4.fc27

How reproducible:
100%

Steps to Reproduce:
1. Remove BuildRequires: fedfs-utils-devel from spec file
2. rebuild nfs-utils
3. Check Provides

Actual results:
builds with no problems, still has the same provides.

Expected results:
Something to fail, or not provide something.

Additional info:
This is part of bootstrapping.  We're trying to slim down the number of packages needed to bootstrap.  Many things need nfs-utils, but nothing else needs fedfs-utils.  If nfs-utils doesn't really need fedfs-utils, it would be great if we could take it out of bootstrap.

Note You need to log in before you can comment on or make changes to this bug.