Bug 1472530 - [starter][starter-us-east-1] Unable to mount volumes to pod (mongo)
[starter][starter-us-east-1] Unable to mount volumes to pod (mongo)
Status: CLOSED DUPLICATE of bug 1481729
Product: OpenShift Online
Classification: Red Hat
Component: Storage (Show other bugs)
3.x
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Hemant Kumar
Jianwei Hou
: OnlineStarter
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-18 21:38 EDT by Steve Speicher
Modified: 2017-09-13 16:56 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-13 16:56:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Speicher 2017-07-18 21:38:30 EDT
Deployed stock nodejs+mongo sample on starter-us-east-1 and failed to deploy with:

9:21:26 PM	mongodb-1-mszl7	Pod	Warning	Failed mount 	Unable to mount volumes for pod "mongodb-1-mszl7_sspeiche3(102edc0d-6c1f-11e7-baff-12d641ec7610)": timeout expired waiting for volumes to attach/mount for pod "sspeiche3"/"mongodb-1-mszl7". list of unattached/unmounted volumes=[mongodb-data default-token-r8nf7]

namespace: sspeiche3

OpenShift Master:
v3.6.126.1 (online version 3.5.0.20)
Kubernetes Master:
v1.6.1+5115d708d7

I don't have access to cluster logs, so ping dakini or eparis if needed.
Comment 5 Nathan Knight 2017-08-27 01:03:22 EDT
I was told to report that I'm having the same issue.

=====================
If you're still facing the issue, please CC yourself to the bug and post a comment that you're facing the same, mentioning the problematic node (ip-172-31-55-219.ec2.internal/172.31.55.219) and the volume that failed to mount ('FailedMount Unable to mount volumes for pod "django-psql-persistent-1-build_knight-guru(dd9c0ae8-88e5-11e7-9fd7-12d641ec7610)": timeout expired waiting for volumes to attach/mount for pod "knight-guru"/"django-psql-persistent-1-build". list of unattached/unmounted volumes=[docker-socket builder-dockercfg-z8rnt-push builder-token-40rw4]').
=====================


Why are we being forced off of v2 gears if v3 pods aren't ready for prime time?  This problem is happening no matter which pod combination I choose.  I've faced the same issue whether I choose a PHP pod, a JS pod, or a Python pod...
Comment 7 Bradley Childs 2017-09-13 16:56:23 EDT

*** This bug has been marked as a duplicate of bug 1481729 ***

Note You need to log in before you can comment on or make changes to this bug.