Bug 1472585 - expose common settings for custom-hiera.yaml
expose common settings for custom-hiera.yaml
Status: CLOSED DUPLICATE of bug 1443138
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
Depends On:
  Show dependency treegraph
Reported: 2017-07-19 00:30 EDT by sbadhwar
Modified: 2017-08-04 10:11 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2017-08-04 10:11:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description sbadhwar 2017-07-19 00:30:47 EDT
Description of problem:
The performance brief for Red Hat Satellite mentions several tuning which cannot be persisted across the upgrades of Satellite. On drilling down the issue, it appears that, the puppet modules that ship with the satellite-installer does not have the specific settings exposed through them.

Some of the settings that are missing support include:
1). QPID max-connections under /etc/qpid/qpidd.conf
2). max_connections under /var/lib/pgsql/data/postgresql.conf
3). PassengerMaxPoolSize under /etc/httpd/conf.d/passenger.conf

Can we expose these settings through the puppet modules that ship with the satellite-installer

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:

Actual results:

Expected results:

Additional info:
Comment 2 Brad Buckingham 2017-08-04 10:11:35 EDT

*** This bug has been marked as a duplicate of bug 1443138 ***

Note You need to log in before you can comment on or make changes to this bug.