Bug 147261 - tkcvs for the x86_64 platform fails on the x86_64 platform
Summary: tkcvs for the x86_64 platform fails on the x86_64 platform
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: tkcvs (Show other bugs)
(Show other bugs)
Version: 3
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Gérard Milmeister
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-05 17:04 UTC by Mercury Morris
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version: 7.2.2-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-15 00:16:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mercury Morris 2005-02-05 17:04:16 UTC
Description of problem:

On a 2.6.9-1.681_FC3 system,
running tkcvs fails with this error:

Error in startup script: invalid command name "get_cde_params"
  while executing
"get_cde_params"
  (file "/usr/bin/tkcvs" line 1)


Version-Release number of selected component (if applicable):
7.2.1-1


How reproducible:

Install the tkcvs-7.2.1-1.noarch.rpm from x86_64 Fedora-Extras
and then invoke the command, tkcvs.


Steps to Reproduce:
1. On an up-to-date, properly set up AMD64 system, use yum
   to install tkcvs FROM THE x86_64 Fedroa-Extras REPOSITORY.
2. Enter the command, tkcvs
3.
  
Actual results:
 The command, tkcvs, fails with the error noted above.

Expected results:
 The tkcvs main menu should be displayed.

Additional info:
 The tkcvs-7.2.1-1.noarch.rpm package FROM THE x86_64
 REPOSITORY, stores the components in /usr/lib64/tkcvs
 as opposed to /usr/lib/tkcvs.  This might be the reason
 for the failure.  To try to get tkcvs to work, I installed
 the tkcvs-7.2.1-1.noarch.rpm FROM THE i386 REPOSITORY,
 and the failure did not occur.

Comment 1 Gérard Milmeister 2005-02-14 16:07:29 UTC
The tkcvs noarch is now in Extras for x86_64.

Comment 2 Mercury Morris 2005-02-14 18:45:51 UTC
tkcvs still fails on the x86_64 platform.

To get tkcvs to work correctly on the x86_64 platform,
the i386 version of tkcvs must be installed there.

One other note about the latest tkcvs rpm is that now
two dependencies have been added that weren't there before:

Either version of tkcvs (x86_64 or i386) now requires both
tcl-devel and tk-devel.  In fact, neither of these "devel"
packages is needed by tkcvs.

Observing that not one other tkcvs user has commented that
tkcvs fails on the x86_64 platform, I will suspend further
activity on this bug.  I might resume the pursuit of this
bug, should any other tkcvs user finds the same failure.

Thanks for looking at this bug.


Comment 3 Gérard Milmeister 2005-02-14 19:28:31 UTC
Please try to build this:
http://www.ifi.unizh.ch/staff/milmei/rpms/tkcvs-7.2.2-2.src.rpm
on x86_64, and report how it works.

Comment 4 Michael Schwendt 2005-02-14 19:41:51 UTC
Aurelien, Thorsten, could either of you please assist?

Comment 5 Aurelien Bompard 2005-02-14 21:26:32 UTC
The srpm in comment 3 builds fine here on x86_64. When I run tkcvs, the window
appears. Do you need any more testing ?

Comment 6 Thorsten Leemhuis 2005-03-23 18:50:36 UTC
tkcvs-7.2.2-2.noarch.rpm is out since Feb 20 -- is this bug still valid or can
it be closed?

Comment 7 Mercury Morris 2005-03-24 15:15:12 UTC
Sorry for the delay in trying tkcvs-7.2.2-2.noarch.rpm.

After installing tkcvs-7.2.2-2.noarch.rpm on a x86_64
system, the bug is gone and the tkcvs window appears
as expected.

Apparantly, I failed to notice that on Feb. 20, a new
version of tkcvs was available.  I saw it every day on
the list of updates produced by yum, but made sure to
EXCLUDE tkcvs when updating systems here.

Thank you for updating tkcvs, and for the (gentle) reminder
that a new version was available.

Please close this bug.




Note You need to log in before you can comment on or make changes to this bug.