Bug 1472640 - Disabled touchpad gets re-enabled after sleep
Disabled touchpad gets re-enabled after sleep
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
26
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-19 03:14 EDT by Ken Sugawara
Modified: 2018-03-13 10:54 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-13 10:54:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
"rpm -qa" output (66.12 KB, text/plain)
2017-08-18 01:34 EDT, Ken Sugawara
no flags Details

  None (edit)
Description Ken Sugawara 2017-07-19 03:14:54 EDT
Description of problem:
Disabled touchpad gets re-enabled after waking up from sleep

Version-Release number of selected component (if applicable):
kernel-4.11.9-300.fc26.x86_64


How reproducible:
Always (100%)


Steps to Reproduce:
1. Disable touchpad in Gnome settings
2. Close the laptop screen to go to sleep
3. Reopen the lid to wake it up

Actual results:
Touchpad is enabled. It remains enabled until I enable and disable it again in the mouse and touchpad settings.


Expected results:
Touchpad is disabled

Additional info:
I didn't see this in Fedora 25.
Hardware is ThinkPad T460s.
Touchpad is even disabled in BIOS config.
Comment 1 Robert de Rooy 2017-08-17 07:22:04 EDT
Have the exact same issue on a ThinkPad X1 Yoga (2016 model).
But I can also reproduce it on a T430u, but not on a regular T430.
Comment 2 Ken Sugawara 2017-08-18 01:34 EDT
Created attachment 1315044 [details]
"rpm -qa" output
Comment 3 Ken Sugawara 2017-08-18 01:35:42 EDT
I've been updating my laptop pretty regularly but the problem hasn't gone away. I've attached the output from "rpm -qa" just in case.
Comment 4 Justin Chiu 2017-09-06 02:28:14 EDT
Also experiencing this on my T470.
Comment 5 Robert de Rooy 2017-09-17 12:29:34 EDT
FYI, I have updated one of my systems to the pre-beta F27, and this issue is gone. Not that I would recommend updating at this time, as I had a bunch of new issues (luckily already listed as blockers for final-F27).
Comment 6 Laura Abbott 2018-02-27 22:46:22 EST
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale. The kernel moves very fast so bugs may get fixed as part of a kernel update. Due to this, we are doing a mass bug update across all of the Fedora 26 kernel bugs.
 
Fedora 26 has now been rebased to 4.15.4-200.fc26.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 27, and are still experiencing this issue, please change the version to Fedora 27.
 
If you experience different issues, please open a new bug report for those.
Comment 7 Robert de Rooy 2018-03-01 05:01:55 EST
I have not encountered this issue since upgrading to F27. Don't know if it is still an issue on F26.
Comment 8 Ken Sugawara 2018-03-13 02:06:12 EDT
I've moved on to F27 as well. You can close this now.
Comment 9 Laura Abbott 2018-03-13 10:54:57 EDT
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.