Bug 1472642 - Heketi : Node remove should wait if heal is in progress.
Heketi : Node remove should wait if heal is in progress.
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi (Show other bugs)
cns-3.6
Unspecified Unspecified
unspecified Severity high
: ---
: CNS 3.6
Assigned To: Michael Adam
Apeksha
:
Depends On:
Blocks: 1358188 1445448
  Show dependency treegraph
 
Reported: 2017-07-19 03:20 EDT by Mohamed Ashiq
Modified: 2017-10-11 03:07 EDT (History)
8 users (show)

See Also:
Fixed In Version: heketi-5.0.0-8 rhgs-volmanager-docker-5.0.0-10
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-11 03:07:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohamed Ashiq 2017-07-19 03:20:20 EDT
Description of problem:
Node remove doesn't check if the self heal is complete before continuing to next device in node.
Comment 7 Raghavendra Talur 2017-08-30 03:34:13 EDT
The upstream patch is https://github.com/heketi/heketi/pull/834
Comment 8 Apeksha 2017-09-15 07:05:49 EDT
Verified on build on build cns-deploy-5.0.0-37.el7rhgs.x86_64 and heketi-client-5.0.0-11.el7rhgs.x86_64
Comment 9 errata-xmlrpc 2017-10-11 03:07:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2879

Note You need to log in before you can comment on or make changes to this bug.