Bug 147265 - Pressing [ on node 1.6 of the tutorial causes a segfault
Pressing [ on node 1.6 of the tutorial causes a segfault
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: texinfo (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-05 13:41 EST by Jeff Mitchell
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 4.8-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-06 14:09:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Mitchell 2005-02-05 13:41:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
I talked to the maintainer of texinfo and he said he believes this bug
to be fixed in texinfo 4.8 which was released a few weeks ago.  So
hopefully we can get an RPM of that in the repository.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Type "info info"
2. Press ] until you're at node 1.6
3. Press [ to go to the previous node
    

Actual Results:  Seg fault

Expected Results:  Back to the previous node

Additional info:
Comment 1 Sitsofe Wheeler 2005-02-05 19:58:07 EST
After installing texinfo-debuginfo valgrind had this to say:
==15711== Conditional jump or move depends on uninitialised value(s)
==15711==    at 0x80579EF: ??? (session.c:1973)
==15711==    by 0x8057AD8: ??? (session.c:883)
==15711==    by 0x80584DF: ??? (session.c:1103)
==15711==    by 0x805C2A6: ??? (session.c:4646)
==15711==
==15711== Invalid read of size 4
==15711==    at 0x80579EA: ??? (session.c:1973)
==15711==    by 0x8057F25: ??? (session.c:1085)
==15711==    by 0x8058493: ??? (session.c:1119)
==15711==    by 0x805C2A6: ??? (session.c:4646)
==15711==  Address 0x14 is not stack'd, malloc'd or (recently) free'd
==15711==
==15711== Process terminating with default action of signal 11 (SIGSEGV)
==15711==  Access not within mapped region at address 0x14
==15711==    at 0x80579EA: ??? (session.c:1973)
==15711==    by 0x8057F25: ??? (session.c:1085)
==15711==    by 0x8058493: ??? (session.c:1119)
==15711==    by 0x805C2A6: ??? (session.c:4646)

(this was for texinfo-4.7-5)
I didn't dig any further because as Jeff mentioned it sounds like there are
fixes to session.c in later texinfo packages (see
http://savannah.gnu.org/cgi-bin/viewcvs/texinfo/texinfo/ChangeLog?rev=HEAD )

Note You need to log in before you can comment on or make changes to this bug.