Bug 1472668 - [RFE] Adding support for config macsec via classical network scripts
[RFE] Adding support for config macsec via classical network scripts
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: initscripts (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: David Kaspar [Dee'Kej]
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-19 03:46 EDT by Frank Büttner
Modified: 2017-07-19 07:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-19 07:45:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Büttner 2017-07-19 03:46:56 EDT
Description of problem:
The NetworkManger know's options for macsec.
https://developer.gnome.org/NetworkManager/stable/settings-macsec.html

But under /usr/share/doc/initscripts-9.49.37/sysconfig.txt nothing about the it for the classical script's are noted.

Version-Release number of selected component (if applicable):
initscripts-9.49.37-1
Comment 2 David Kaspar [Dee'Kej] 2017-07-19 07:45:08 EDT
Hello Frank,

the initscripts are bash scripts which have its own limitations. That's one of the reasons why the NetworkManager was created - to supersede these limitations.

Adding support for MACsec into initscripts is RFE, which is too much complex to be worth all the trouble. Especially because in the distant future, we expect that network-scripts (part of init-scripts) will most likely be completely replaced by NetworkManager and/or networkd.

The best advice I can give you is to use NetworkManager for what you need, or you just the wpa_supplicant, as described in these 2 blog articles:

* https://developers.redhat.com/blog/2016/10/14/macsec-a-different-solution-to-encrypt-network-traffic/
* https://developers.redhat.com/blog/2017/06/28/whats-new-in-macsec-setting-up-macsec-using-wpa_supplicant-and-optionally-networkmanager/

Best regards,

David

Note You need to log in before you can comment on or make changes to this bug.