Bug 1472732 - /etc/redhat-storage-release file containing the image name is missing in rhgs-s3-server-rhel7 container image
/etc/redhat-storage-release file containing the image name is missing in rhgs...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhgs-s3-server-container (Show other bugs)
cns-3.6
Unspecified Unspecified
medium Severity medium
: ---
: CNS 3.6
Assigned To: Mohamed Ashiq
Prasanth
:
Depends On:
Blocks: 1445448
  Show dependency treegraph
 
Reported: 2017-07-19 05:49 EDT by Prasanth
Modified: 2017-10-11 03:01 EDT (History)
8 users (show)

See Also:
Fixed In Version: rhgs-s3-server-docker-3.3.0-4
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-11 03:01:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
suprasad: needinfo-


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:2880 normal SHIPPED_LIVE rhgs-s3-server-container bug fix and enhancement update 2017-10-11 07:14:53 EDT

  None (edit)
Description Prasanth 2017-07-19 05:49:37 EDT
Description of problem:

/etc/redhat-storage-release file containing the image name is missing in the rhgs-s3-server-rhel7 container image

#####
# oc rsh glusters3
sh-4.2# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.4 Beta (Maipo)
sh-4.2# cat /etc/redhat-storage-release
cat: /etc/redhat-storage-release: No such file or directory
sh-4.2# cat /etc/redhat-storage-release
#####

Version-Release number of selected component (if applicable):
rhgs3/rhgs-s3-server-rhel7:3.3.0-3

How reproducible: Always


Steps to Reproduce:
1. Get into the s3 pod and cat the file /etc/redhat-storage-release
2.
3.

Actual results: 
/etc/redhat-storage-release file containing the image name is missing


Expected results:
/etc/redhat-storage-release file containing the image name should be present inside the container. And since this image is a Tech Preview for this release, the image name should reflect the same as well.



Additional info:
Comment 2 Sahina Bose 2017-07-24 08:50:47 EDT
Red Hat Gluster S3 Service 3.3 ( Container) (Tech Preview) - can we have this name for the container?
Comment 6 Prasanth 2017-07-24 10:30:07 EDT
For reference, please find the existing names of the RHGS and Heketi container images below:


* From rhgs3/rhgs-server-rhel7 image:
# cat /etc/redhat-storage-release 
Red Hat Gluster Storage Server 3.3(Container)


* From rhgs3/rhgs-volmanager-rhel7 image:
# cat /etc/redhat-storage-release 
Red Hat Gluster Volume Manager 3.3 ( Container)
Comment 7 Sudhir 2017-07-25 05:41:12 EDT
Let's start using the new name of the product

Red Hat CNS S3 Interface (Container)
Comment 8 Sahina Bose 2017-07-25 06:58:12 EDT
(In reply to Sudhir from comment #7)
> Let's start using the new name of the product
> 
> Red Hat CNS S3 Interface (Container)

with (Tech Preview) , I think?
Comment 9 Sudhir 2017-07-25 11:13:26 EDT
Red Hat CNS S3 Interface Tech Preview (Container)

sounds good
Comment 15 Mohamed Ashiq 2017-08-03 03:12:50 EDT
Changes have been made in the dist git. Next build have this fix.
Comment 16 Prasanth 2017-08-29 07:54:03 EDT
Verified as Fixed in rhgs-s3-server-rhel7:3.3.0-6

# oc rsh glusters3-1-qs44r
cacash-4.2# cat /etc/redhat-storage-release 
Red Hat Gluster Storage S3 Server (Container)
Comment 17 Saravanakumar 2017-08-31 09:26:26 EDT
It is updated as below to reflect tech preview :

Red Hat CNS S3 Interface 3.3 Tech Preview (Container)
Comment 18 Sudhir 2017-09-05 02:40:01 EDT
Let me know if anything else is outstanding here.
Comment 19 Prasanth 2017-09-13 11:51:59 EDT
(In reply to Saravanakumar from comment #17)
> It is updated as below to reflect tech preview :
> 
> Red Hat CNS S3 Interface 3.3 Tech Preview (Container)

Verified the above change.


# oc rsh gluster-s3-dc-1-6sglz
sh-4.2# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.4 Beta (Maipo)
sh-4.2# cat /etc/redhat-storage-release 
Red Hat CNS S3 Interface 3.3 Tech Preview (Container)
Comment 21 errata-xmlrpc 2017-10-11 03:01:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2880

Note You need to log in before you can comment on or make changes to this bug.