Bug 1472746 - GUI: Cannot sort My Subscriptions Tab by end date
Summary: GUI: Cannot sort My Subscriptions Tab by end date
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.4
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Jiri Hnidek
QA Contact: John Sefler
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-07-19 10:36 UTC by Shwetha Kallesh
Modified: 2018-04-10 09:50 UTC (History)
4 users (show)

(edit)
undefined
Clone Of:
(edit)
Last Closed: 2018-04-10 09:49:52 UTC


Attachments (Terms of Use)
Cannot sort My Subscriptions Tab by end date (194.23 KB, image/png)
2017-07-19 10:36 UTC, Shwetha Kallesh
no flags Details
Subman GUI sorting subscriptions by date (62.51 KB, image/png)
2017-07-21 09:21 UTC, Jiri Hnidek
no flags Details
Subman GUI sorting subscriptions by date (reversed) (63.41 KB, image/png)
2017-07-21 09:23 UTC, Jiri Hnidek
no flags Details
Sorts by End Date (222.53 KB, image/png)
2017-11-10 10:56 UTC, Shwetha Kallesh
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0681 None None None 2018-04-10 09:50 UTC
Github candlepin subscription-manager pull 1670 None None None 2017-07-21 10:40 UTC

Description Shwetha Kallesh 2017-07-19 10:36:30 UTC
Created attachment 1300960 [details]
Cannot sort My Subscriptions Tab by end date

Description of problem:
GUI: Cannot sort All Available Subscriptions Tab by end date

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
Register and attach 2 subscriptions that has different end dates
Launch GUI and go to My Subscriptions Tab , try to sort subscriptions by End date

Actual results:
 Cannot sort My Subscriptions Tab by end date

Expected results:
My Subscriptions Tab should be sortable by end date

Additional info:
P.S Attachment

Comment 2 Jiri Hnidek 2017-07-21 09:21 UTC
Created attachment 1302232 [details]
Subman GUI sorting subscriptions by date

Comment 3 Jiri Hnidek 2017-07-21 09:23 UTC
Created attachment 1302234 [details]
Subman GUI sorting subscriptions by date (reversed)

I can confirm that clicking at date does not have any effect. I'm taking this bug report.

Comment 5 Shwetha Kallesh 2017-11-10 10:56 UTC
Created attachment 1350416 [details]
Sorts by End Date

Verified!! Sorts by end date now

[root@dhcp35-121 ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 2.2.0-1
subscription management rules: 5.26
subscription-manager: 1.20.5-1.el7

Comment 8 errata-xmlrpc 2018-04-10 09:49:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0681


Note You need to log in before you can comment on or make changes to this bug.