Bug 147276 - strange behavior when using Expect script
strange behavior when using Expect script
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-05 21:00 EST by Marc Williams
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 5.43.0-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-03 01:19:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marc Williams 2005-02-05 21:00:02 EST
Description of problem:
When a small Expect script (one that SSH's into other machines) is
started from within gnome-terminal, subsequent user (non-script)
commands that produce lots of stdout cause gnome-term to stutter while
producing the output and to never finish.


Version-Release number of selected component (if applicable):
2.73, I think.

How reproducible:
Every time

Steps to Reproduce:
1. start the Expect script in a gnome-terminal
2. the script SSH's into a remote machine and performs login tasks
3. when the script is finished, run ls -la on a large directory such
as /usr/bin (or cat a large text file or anything else that produces
lots of output)
  
Actual results:
The output (of the large output task) never finishes.  Rather, it gets
"stuck" somewhere in the middle of the output and "stutters".  This is
hard to describe.  The output will wiggle around on the screen, the
cursor jumps around a bit, and the whole thing is quite hard to read
or follow because of this.

Expected results:


Additional info:
At first I thought there might be something wrong with the Expect
script or maybe the version I run.  But then I ran the same thing in
several other terms successfully.  Specifically, xterm, eterm, aterm,
and multi-gnome-terminal all run the script flawlessly with none of
the behavior I described above.  Only when running my script in
gnome-terminal does this happen.  Making this even more mind-bending,
if I take the commands in the script and run them manually in a
gnome-terminal, I get none of this weird behavior.

I contemplated upgrading gnome-terminal when I noticed that there is a
newer stable release, 2.92 I think, but changed my mind when I saw
that it depended upon newer GTK libs and such.
Comment 1 Marc Williams 2005-02-15 13:58:27 EST
Never mind.  Sorry.  The problem wasn't with gnome-terminal at all but rather
with Expect itself.  A newer version of Expect was released this week which
fixed the problem.

I hope a newer RPM can be built as this was a pretty nasty bug.
Comment 2 Jens Petersen 2005-10-03 01:19:05 EDT
Closing based on previous comment since 5.43.0 is in FC4.

Note You need to log in before you can comment on or make changes to this bug.