Bug 1472772 - [UI] - re-add context menus to grids
[UI] - re-add context menus to grids
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
4.2.0
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-4.2.0
: ---
Assigned To: Alexander Wels
Petr Matyáš
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-19 07:37 EDT by Petr Matyáš
Modified: 2017-12-20 05:42 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 05:42:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 83729 master MERGED webadmin: restore context menu 2017-11-08 18:40 EST

  None (edit)
Description Petr Matyáš 2017-07-19 07:37:39 EDT
Description of problem:
When using right mouse button for context menu on some table element e.g. one particular VM, there used to be menu with options to start|stop|run once...., now it's not there and only general browser context menu is present.

This is true for all items, hosts, clusters, storages....

Version-Release number of selected component (if applicable):
ovirt-engine-4.2.0-0.0.master.20170719072402.gitca6b518.el7.centos.noarch

How reproducible:
always

Steps to Reproduce:
1. open VMs tab
2. open context menu for particular VM
3.

Actual results:
only general context menu appears

Expected results:
context menu with items relevant for RHV appears

Additional info:
Comment 1 Oved Ourfali 2017-07-19 08:22:05 EDT
We are pending decision on whether to support that, as it is not aligned with UXD guidelines.
Comment 2 Greg Sheremeta 2017-10-02 07:28:57 EDT
After discussion with PM, we've decided to keep the custom context menu removed for now. We can revisit in the future if we see many user complaints.
Comment 3 Greg Sheremeta 2017-11-07 14:49:36 EST
(In reply to Greg Sheremeta from comment #2)
> After discussion with PM, we've decided to keep the custom context menu
> removed for now. We can revisit in the future if we see many user complaints.

After discussion on the ovirt users list, and consulting with the PatternFly team, we've decided it makes sense to re-add the context menu.
Comment 4 Oved Ourfali 2017-11-08 02:08:23 EST
Note that the right click added will contain the buttons that are at the upper panel, as those are expected to be the ones used mostly.
It will only contain single buttons (not menus), as currently there is no representation of sub menus on right click in bootstrap.
It will not contain the buttons that appear when you press the three dots. If one of these buttons is widely used, it should move to the action panel (requires code change), and then it will also be automatically added to the context menu (no code change needed).
Comment 5 Petr Matyáš 2017-11-14 10:38:12 EST
Verified on ovirt-engine-4.2.0-0.0.master.20171113223918.git25568c3.el7.centos.noarch
Comment 6 Sandro Bonazzola 2017-12-20 05:42:32 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.