Bug 147278 - Anaconda downgraded Firefox after in-use Update
Summary: Anaconda downgraded Firefox after in-use Update
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-06 04:18 UTC by Dennis P. Costea Jr.
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 21:09:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dennis P. Costea Jr. 2005-02-06 04:18:24 UTC
Description of problem:
Firefox was installed with my system and updated using the Red Hat
Network Alert Notification Tool and up2date.  Firefox 0.10.1 installed
during initial install, and I believe it was updated with 166 other
packages shortly after the initial install.

Afterwards I wanted to Add the HTML document authoring package from
the Fedora Core 3 DVD but could not due to an error regarding a
missing "samba-client"; required to Continue.  So as an alternative
approach I left the Fedora Core 3 DVD in the drive during the next
Reboot and allowed the Anaconda installer to run again.  I selected
all the option for Upgrading packages, not Installing/reinstalling,
and it APPEARS that my up2date version firefox-1.0-2.fc3 was
overwritten back to firefox 0.10.1 (as if the installer could not
detect an updated version existed on the volume).

Version-Release number of selected component (if applicable):
Firefox 0.10.1
Up2dated to Firefox-1.0-2.fc3
Then Anaconda-ed back down to Firefox 0.10.1

How reproducible:
Unknown; do not want to attempt these steps again.  I will allow
up2date to re-Add the new Firefox package.

Steps to Reproduce:
1. Install Fedora Core 3 from DVD.
2. Update the Firefox browser using up2date.
3. Allow Anaconda to run AGAIN a short time later
   and see if it reinstalls the ORIGINAL Firefox
   package without opportunity to [Cancel].
  
Actual results:
As described above.

Expected results:
Would have expected the Anaconda installer to detect firefox-1.0-2.fc3
update and NOT reinstall the original DVD distributed package.

Additional info:
I did not see a screen allowing me a choice in which packages need to
be Installed versus Upgraded while Anaconda was running the second time.

Comment 1 Jeremy Katz 2005-02-07 15:28:07 UTC
Can you please provide /root/upgrade.log and /var/log/anaconda*

Comment 2 Jeremy Katz 2005-09-21 21:09:35 UTC
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproduceable or has been fixed in
a later update for this product.  If you have further details, feel free to
reopen the report with the additional details attached.


Note You need to log in before you can comment on or make changes to this bug.