Bug 147281 - FC3 rebuild of rawhide kernel fails (incorrect hardlink dependency)
FC3 rebuild of rawhide kernel fails (incorrect hardlink dependency)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-06 01:36 EST by Barry K. Nathan
Modified: 2015-01-04 17:16 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.6.11-1.1173_FCx
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-15 00:17:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Barry K. Nathan 2005-02-06 01:36:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041224

Description of problem:
The spec file for kernel 2.6.10-1.1125_FC4 has an RPM %define for
building on FC3 instead of FC4. However, even with the %define's
adjusted (%define FC3 1 and %define FC4 0), rebuilding on FC3 fails.

I was going to attach a patch to make the dependency depend on %{FC3}
and %{FC4}, but I've looked through the spec file now and I don't see
why hardlink is a BuildPreReq in the first place. It gets used at
package install time, if it's present, but I don't see where it gets
used at build time.

Version-Release number of selected component (if applicable):
2.6.10-1.1125_FCx

How reproducible:
Always

Steps to Reproduce:
1. Install rawhide kernel SRPM.
2. Change %define FC3 to 1, and %define FC4 to 0.
3. Try rebuilding (e.g. "rpmbuild -ba --target i686
SPECS/kernel-2.6.spec")
    

Actual Results:  Building target platforms: i686
Building for target i686
error: Failed build dependencies:
        hardlink is needed by kernel-2.6.10-1.1125_FC3.barryn.i686


Expected Results:  Build should succeed (or at least, it shouldn't
fail for this particular reason).

Additional info:
Comment 1 Barry K. Nathan 2005-02-06 09:23:05 EST
Once I remove the hardlink dependency, recompiling for FC3 works, as
does running the resulting kernel on FC3.
Comment 2 Barry K. Nathan 2005-03-15 00:15:23 EST
Seems to be fixed in recent rawhide (2.6.11-1.1172_FCx or so).
Comment 3 Barry K. Nathan 2005-03-15 00:17:08 EST
Oops, I meant 1173, not 1172.

Note You need to log in before you can comment on or make changes to this bug.