Bug 1472826 - Wacom Left-Handed Orientation ON setting is forgotten on every reboot
Wacom Left-Handed Orientation ON setting is forgotten on every reboot
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-wacom (Show other bugs)
26
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-19 09:20 EDT by David
Modified: 2017-09-07 18:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-07 18:34:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a screen dump right after a reboot when the bug is happening (69.62 KB, image/png)
2017-07-21 04:31 EDT, David
no flags Details

  None (edit)
Description David 2017-07-19 09:20:38 EDT
Description of problem:

When Fedora 26 boots 9/10 times it forgets that I turned on the Left-Handed option in the Wacom settings. If I then merely open the Wacom settings panel it immediately remembers and starts working.


Version-Release number of selected component (if applicable):

Fedora 26, updated to 19th July 2017

How reproducible:


Steps to Reproduce:

1. set Left-Handed Orientation ON in the Wacom settings
2. reboot
3. 9/10 times it is not working, the setting has been forgotten

Actual results: the setting has been forgotten


Expected results: the setting would be remembered


Additional info:

I don't know if this is an xorg-drv-wacom problem or a Gnome problem, this is my first bug report., i don't really know the difference! I just guessed... some more newbie friendly bug reporting would be welcome :)
Comment 1 Peter Hutterer 2017-07-21 00:17:26 EDT
Most likely a gnome bug. Run:

dconf dump /  | grep -A5 tablets

That should list something like:
[org/gnome/desktop/peripherals/tablets/056a:00b9]
left-handed=false
mapping='absolute'

The 00b9 is the usb product ID, expect that to be different. Once you know that path though you can run:

gsettings get org.gnome.desktop.peripherals.tablet:/org/gnome/desktop/peripherals/tablets/056a:00e6/ left-handed

to check if it's set (left_handed=false is the same)

Run that when it's on and when it's off, does the gsettings reflect this?
Comment 2 David 2017-07-21 04:31 EDT
Created attachment 1302213 [details]
a screen dump right after a reboot when the bug is happening
Comment 3 David 2017-07-21 04:36:10 EDT
Hello Peter,

I did as you said, and have attached a screen-dump showing the results.

It says left handed true in both cases when it is not actually working in the real world.

Thanks, can you deal with this, or do I need to take further action?

This is my first bug report and I have no idea about protocol :)
Comment 4 Peter Hutterer 2017-07-23 19:13:01 EDT
fwiw, you can just highlight the output and paste it here. or (if it's a lot of lines) copy it into a text file and then use the add an attachment link above.

anyway, looks like the gnome setting is set correctly, so please do this now:
run xinput list-props "<device name>", substituting the device name for the tablet device (check the xinput list output). Do this when it doesn't work, then do it again when it works. Attach both of the outputs here, thanks.
Comment 5 David 2017-07-25 05:49:35 EDT
Since I logged into a Wayland Gnome session (for the first time) this bug is not happening any more! I think that changed something, but it is still obviously a bug.

I used Wayland once just to test it, and it is still useless for using a Wacom tablet to control the computer. Still 2 mouse cursors and Firefox not being usable (not gtk3 I understand?)

I am not sure how I would test this without formatting the entire computer and starting again without using Wayland?

The only other explanation is a set of updates I installed, but I think it is more likely the Wayland login as the updates did not look relevant.

If there is anything else I could do please let me know, cheers!
Comment 6 Peter Hutterer 2017-09-05 18:08:49 EDT
sorry, this came in while I was travelling and I've been trying to catch up since. First: is this still a problem?

>  am not sure how I would test this without formatting the entire computer and starting again without using Wayland?

not 100% sure what you mean here, but you can just select "GNOME on Xorg" at the login screen by clicking the little gear icon. selecting GNOME gets you back to Wayland then.
Comment 7 David 2017-09-06 05:01:30 EDT
Hi Peter,

The bug is not happening anymore, but I am not sure if the solution was:

1. I logged into Wayland for the first time, and then it worked in Xorg
2. I did a dnf update

I did both these things at about the same time, so I can't say which one cured the problem.

Someone would need to run Fedora with a Wacom tablet without ever booting into Wayland as I did to test this.
Comment 8 Peter Hutterer 2017-09-07 18:34:24 EDT
hmm, guess we'll have to close this then until someone figures out how to reproduce it. thanks for following up on it though, sorry about the delay.

Note You need to log in before you can comment on or make changes to this bug.