Bug 1472855 - Filters under Job Templates do not work properly
Filters under Job Templates do not work properly
Status: CLOSED CURRENTRELEASE
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.8.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.10.0
Assigned To: Hilda Stastna
Dave Johnson
: TestOnly
: 1500950 (view as bug list)
Depends On:
Blocks: 1510240 1510241
  Show dependency treegraph
 
Reported: 2017-07-19 10:22 EDT by Hilda Stastna
Modified: 2018-06-21 16:32 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1510240 1510241 (view as bug list)
Environment:
Last Closed: 2018-06-21 16:32:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: CFME Core


Attachments (Terms of Use)
filtering of Job Templates does not work properly (2.86 MB, image/png)
2017-07-19 10:22 EDT, Hilda Stastna
no flags Details

  None (edit)
Description Hilda Stastna 2017-07-19 10:22:03 EDT
Created attachment 1301131 [details]
filtering of Job Templates does not work properly

Description of problem:
Clicking on a filter in accordion under Job Templates does not filter but leads to 'All Configured Systems' screen which is related to other tab in accordion.

Version-Release number of selected component (if applicable):
5.7, 5.8.

How reproducible:
always

Steps to Reproduce:
1. Go to Automation -> Ansible Tower -> Explorer 
2. Go to Job Templates tab in accordion
3. Go to Advanced Search and create a filter (no matter if global or not)
4. Choose the filter under Global Filters or My Filters in accordion under Job Templates tab, click on it

Actual results:
Using filters from accordion under Job Templates does not work, it shows All Configured Systems which belongs to Configured Systems tab in accordion, not Job Templates tab, which is wrong.

Expected results:
Clicking on a filter should provide filtering of Job Templates, not going to 'All Configured Systems'.

Additional info:
Comment 2 Hilda Stastna 2017-10-30 12:18:51 EDT
*** Bug 1500950 has been marked as a duplicate of this bug. ***
Comment 3 Hilda Stastna 2017-10-30 12:23:32 EDT
Note: Filtering also does not work when applying a filter from Advanced search.
Comment 4 Hilda Stastna 2017-11-02 10:35:23 EDT
fixing https://github.com/ManageIQ/manageiq-ui-classic/pull/2607

Note You need to log in before you can comment on or make changes to this bug.