Bug 1472894 - app crash when creating storage pool
app crash when creating storage pool
Status: CLOSED DUPLICATE of bug 1457170
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Pavel Hrdina
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-19 11:34 EDT by Cole Robinson
Modified: 2017-07-20 17:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-20 17:13:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cole Robinson 2017-07-19 11:34:16 EDT
virt-manager can crash when creating a storage pool. Reproducer:

- virt-manager --debug --connect test:///default
- Edit->Connection Details->Storage Tab
- + button, name=aaaaaa, type=dir pool, forward, finish

Crashes for me after a few attempts. Using upstream code on fedora it crashes 100% for me

The culprit is the fix for https://bugzilla.redhat.com/show_bug.cgi?id=1435064 : the cb_add_new_pool is usually (always?) called from a non-main thread, but the impl of the function in vmmConnection calls vmmConnection._new_object_cb, which always expects to run in the main thread because it touches UI stuff. Running it from a non-main thread means there will be gtk collisions talking to the X server or accessing internal state, which will give intermittent crashes

For upstream I think the cb_add_new_pool direction is correct but it will need some testing to get it working correctly. I think for RHEL we should revert that patch and solve in a different way. I'll post comments there
Comment 4 tingting zheng 2017-07-19 23:01:26 EDT
Hi,Cole

Actually QE has found this regression bug during rhel7.4 testing,pls see bug 1457170 which can be reproduced all the time,I think they are the same problem,would you pls help to confirm and if so this bug can be closed as duplicated as bug 1457170.
Comment 5 Cole Robinson 2017-07-20 17:13:33 EDT
Yes it's the same bug, I'll dupe

*** This bug has been marked as a duplicate of bug 1457170 ***

Note You need to log in before you can comment on or make changes to this bug.