Bug 147294 - BadWindow / BadAtom error in ssh X11 forwarding
Summary: BadWindow / BadAtom error in ssh X11 forwarding
Status: CLOSED DUPLICATE of bug 137685
Alias: None
Product: Fedora
Classification: Fedora
Component: openssh   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-06 15:59 UTC by Robert K. Moniot
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-07 08:07:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert K. Moniot 2005-02-06 15:59:07 UTC
Description of problem:

From an X session, connect to local or remote host using ssh with X11
forwarding.  Fire up an application, e.g. xterm or emacs and select
some text by clicking and dragging mouse.  Application dies with error
message such as:
X Error of failed request:  BadAtom (invalid Atom parameter)
    Major opcode of failed request:  18 (X_ChangeProperty)
    Atom id in failed request:  0x1a8
    Serial number of failed request:  208
    Current serial number in output stream:  210

or

X protocol error: BadWindow (invalid Window parameter) on protocol
request 38

Workaround: this behavior goes away if ssh -Y option is used or
ForwardX11Trusted=yes is in ssh_config.

Version-Release number of selected component (if applicable):
openssh-3.9p1-7
xorg-x11-6.8.1-12.FC3.21

How reproducible: always


Steps to Reproduce:
1. log on to X
2. ssh somehost
3. xterm &
4. click and drag mouse over some text
  
Actual results:
program dies and closes window with BadWindow or BadAtom error

Expected results:
program should continue running with text selected

Additional info:
See
http://www.brandonhutchinson.com/BadAtom_BadWindow_errors_with_ssh_X11_forwarding.html
for an independent report.

Comment 1 Robert K. Moniot 2005-02-06 16:03:30 UTC
I did some more searching and it seems this is a documented feature,
not a bug.  See http://www.openssh.com/faq.html item 3.13 


Comment 2 Sitsofe Wheeler 2005-02-06 19:35:03 UTC
Yup, it's mentioned in the FC3 release notes too. This a dup of bug #137685

Comment 3 Tomas Mraz 2005-02-07 08:07:52 UTC

*** This bug has been marked as a duplicate of 137685 ***


Note You need to log in before you can comment on or make changes to this bug.