Bug 147295 - tcsh html docs look suspicious
tcsh html docs look suspicious
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: tcsh (Show other bugs)
3.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
Bill Huang
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-06 11:23 EST by nathan r. hruby
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-25 11:32:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nathan r. hruby 2005-02-06 11:23:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/125.5.5 (KHTML, 
like Gecko) Safari/125.12

Description of problem:
The in the docuemnation diretiory for tcsh there is a directory called "tcsh.html" which 
contains HTML documentation for tcsh.  This raises red flags on several of our webservers 
which have scripts that look for directories with common extension names.

Suggest making it tcsh-html or something that doesn't look like a normal file name.

Version-Release number of selected component (if applicable):
tcsh-6.12-11.EL3

How reproducible:
Always

Steps to Reproduce:
1.  Run something that looks for directories with .html at the end of the name
2.
3.
    

Actual Results:  /usr/share/doc/tcsh-6.12/tcsh.html is flagged as suspicious


Expected Results:  Nothing is caught

Additional info:

Don't see anyplace upstream to report bugs :)
Comment 4 Miloslav Trmač 2005-02-25 11:32:22 EST
Hello,
The upstream place to report bugs is mentioned in the man page:
tcsh-bugs@mx.gw.com. I have sent there apointer to this report, including
a possible patch.

I don't think this warrants an RHEL update; in particular I see nothing
wrong with directories called "tcsh.html".

For the future (RHEL-5) the HTML documentation will probably be removed completely
because it just duplicates the man page.

Note You need to log in before you can comment on or make changes to this bug.