Bug 1472978 - DWARF5 support in readelf
DWARF5 support in readelf
Status: CLOSED ERRATA
Product: Red Hat Developer Toolset
Classification: Red Hat
Component: binutils (Show other bugs)
DTS 7.0 RHEL 7
Unspecified Unspecified
unspecified Severity unspecified
: alpha
: 7.0
Assigned To: Nick Clifton
Miloš Prchlík
:
Depends On: 1472955
Blocks: 1472966 1472969 1472971 1472979
  Show dependency treegraph
 
Reported: 2017-07-19 13:32 EDT by Ben Woodard
Modified: 2017-10-24 05:44 EDT (History)
11 users (show)

See Also:
Fixed In Version: binutils-2.28-7.el7
Doc Type: Enhancement
Doc Text:
Feature: Add ability for the readelf tool to recognise new tags introduced in version 5 of the DWARF debug file format standard. Reason: Clang is now producing binaries containing these new tags. Result: Readelf now correctly recognises the new tags.
Story Points: ---
Clone Of: 1472955
Environment:
Last Closed: 2017-10-24 05:44:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Ben Woodard 2017-07-19 13:35:25 EDT
After talking to mjw, the thinking is that it is better to have this be delivered  in DTS than in RHEL.
Comment 3 Nick Clifton 2017-07-20 07:41:11 EDT
Fixed in: binutils-2.28-7.el7
Comment 5 Miloš Prchlík 2017-10-05 16:36:50 EDT
Verified with build devtoolset-7-binutils-2.28-8.el7.
Comment 7 errata-xmlrpc 2017-10-24 05:44:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3007

Note You need to log in before you can comment on or make changes to this bug.