Bug 147301 - anaconda crashes after formating partitions and before installing packages
anaconda crashes after formating partitions and before installing packages
Status: CLOSED DUPLICATE of bug 138419
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-06 13:59 EST by adam klonowski
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-08 14:57:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacdump.txt Text file (789.92 KB, text/plain)
2005-07-08 13:23 EDT, James Sigler
no flags Details

  None (edit)
Description adam klonowski 2005-02-06 13:59:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl-PL; rv:1.7.5)
Gecko/20041108 Firefox/1.0

Description of problem:
i can't install Fedora Core 3 on my computer. anaconda crashes after
formating partitions. i've got similiar problems with instaling FC1
and FC2. i thought it is a problem with my disc but i've formated it
to FAT partition and checked it with windows' scandisc with no results.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.running anaconda
2.configurating instalation and partitioning disc
3.starting instalation
    

Actual Results:  anaconda crashes

Expected Results:  the packages i've chosen should be instaled

Additional info:

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1165, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/src/build/475969-i386/install//usr/lib/anaconda/text.py",
line 507, in run
    dispatch.gotoNext()
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/dispatch.py",
line 171, in gotoNext
    self.moveStep()
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/dispatch.py",
line 239, in moveStep
    rc = apply(func, self.bindArgs(args))
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/packages.py",
line 689, in doPreInstall
    method.mergeFullHeaders(id.grpset.hdrlist)
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/image.py", line
126, in mergeFullHeaders
    hdlist.mergeFullHeaders("%s/%s/base/hdlist2" % (self.tree,
productPath))
  File "/usr/lib/anaconda/hdrlist.py", line 343, in mergeFullHeaders
    rpm.mergeHeaderListFromFD(self.hdlist, fd, 1000004)
error: match tag missing in new header
Comment 1 Jeremy Katz 2005-02-07 10:42:04 EST
Could you please provide the complete anacdump.txt as an attachment?
Comment 2 James Sigler 2005-07-08 13:23:38 EDT
Created attachment 116523 [details]
anacdump.txt Text file

The same thing happens to me every time I try to load FC3 or K12LTSP 4.2.1.  I
attached the anacdump.txt file for you to see.	Can it be fixed?

Thanks,
James Sigler
Comment 3 Jeremy Katz 2005-07-08 14:57:29 EDT

*** This bug has been marked as a duplicate of 138419 ***

Note You need to log in before you can comment on or make changes to this bug.