Bug 147302 - Install update doesn't change boot loader config
Summary: Install update doesn't change boot loader config
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-06 19:28 UTC by jummie2k
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-07 15:45:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description jummie2k 2005-02-06 19:28:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
When using "update" (rather than install) to modify the boot loader
configutration, the changes are not saved.

Since update does not find kernel updates, it displays a message box
reading something like "no kernel upgrades, boot loader configuration
not changed". I think the boot loader configuration is not changed at all.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Download boot cd from ftp mirror (os/images/boot.iso)
2. Install but specify wrong boot loader location (MBR of /dev/hda
instead of /dev/sda)
3. Reboot: boot loader is not started (Windows started here)
4. Reboot with install CD, select update
5. Modify boot loader location (MBR of /dev/sda)
    

Actual Results:  See step 3: boot loader configuration is not changed,
Windows started up again.

Expected Results:  Boot loader should have been started.

Additional info:

I "fixed" it by reinstalling, this time using the correct boot loader
config.

I flagged this bug with i386 platform but I guess I could have
selected "All". I haven't tested though so I didn't.

Comment 1 Jeremy Katz 2005-02-07 15:45:04 UTC
If a kernel package isn't installed, then we don't have the
information to actually create or update boot loader configuration.

Comment 2 jummie2k 2005-02-07 18:23:40 UTC
Isn't all the necessary information present in the already installed
kernel package(s)?

If I understand your comment correctly, the installer's "update"
option does not apply to the boot loader at all:
- If you update Fedora, boot loader is rewritten
- If you don't and change the boot loader, you're screwed.

So the only option is to completely reinstal. That's a pitty. Could
you at least print a message in the installer's help?


Note You need to log in before you can comment on or make changes to this bug.