Bug 1473040 - mock's RPM install scriptlet breaks: "No module named rpmUtils.arch"
mock's RPM install scriptlet breaks: "No module named rpmUtils.arch"
Status: CLOSED DUPLICATE of bug 1461839
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Clark Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-19 19:11 EDT by Lyude
Modified: 2017-07-24 08:30 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-24 08:30:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lyude 2017-07-19 19:11:13 EDT
Description of problem:
When installing mock from fedora 26, the install scriptlet fails (although it isn't fatal to the package install at least.

Version-Release number of selected component (if applicable):
mock-1.4.2-1.fc26

How reproducible:
100%

Steps to Reproduce:
1. sudo dnf install -y mock

Actual results:
➜  piglit git:(master) sudo dnf install mock
Last metadata expiration check: 1:13:22 ago on Wed 19 Jul 2017 05:52:17 PM EDT.
Dependencies resolved.
==============================================================================================================================================================================================================================================
 Package                                                            Arch                                                Version                                                    Repository                                            Size
==============================================================================================================================================================================================================================================
Installing:
 mock                                                               noarch                                              1.4.2-1.fc26                                               fedora                                               162 k
Installing dependencies:
 distribution-gpg-keys                                              noarch                                              1.12-1.fc26                                                updates                                              135 k
 python3-distro                                                     noarch                                              1.0.3-1.fc26                                               fedora                                                31 k

Transaction Summary
==============================================================================================================================================================================================================================================
Install  3 Packages

Total download size: 328 k
Installed size: 934 k
Is this ok [y/N]: y
Downloading Packages:
(1/3): python3-distro-1.0.3-1.fc26.noarch.rpm                                                                                                                                                                 592 kB/s |  31 kB     00:00    
(2/3): distribution-gpg-keys-1.12-1.fc26.noarch.rpm                                                                                                                                                           1.8 MB/s | 135 kB     00:00    
(3/3): mock-1.4.2-1.fc26.noarch.rpm                                                                                                                                                                           1.9 MB/s | 162 kB     00:00    
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                                                                         230 kB/s | 328 kB     00:01     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                                                                                                                                                      1/1 
  Installing       : distribution-gpg-keys-1.12-1.fc26.noarch                                                                                                                                                                             1/3 
  Installing       : python3-distro-1.0.3-1.fc26.noarch                                                                                                                                                                                   2/3 
  Running scriptlet: mock-1.4.2-1.fc26.noarch                                                                                                                                                                                             3/3 
  Installing       : mock-1.4.2-1.fc26.noarch                                                                                                                                                                                             3/3 
  Running scriptlet: mock-1.4.2-1.fc26.noarch                                                                                                                                                                                             3/3 
Traceback (most recent call last):
  File "<string>", line 1, in <module>
ImportError: No module named rpmUtils.arch
Warning: file /etc/mock/fedora-26-.cfg does not exists.
         unable to update /etc/mock/default.cfg
  Verifying        : mock-1.4.2-1.fc26.noarch                                                                                                                                                                                             1/3 
  Verifying        : python3-distro-1.0.3-1.fc26.noarch                                                                                                                                                                                   2/3 
  Verifying        : distribution-gpg-keys-1.12-1.fc26.noarch                                                                                                                                                                             3/3 

Installed:
  mock.noarch 1.4.2-1.fc26                                              distribution-gpg-keys.noarch 1.12-1.fc26                                              python3-distro.noarch 1.0.3-1.fc26                                             

Complete!


Expected results:
Install scriptlet manages to link /etc/mock/default.cfg correctly

Additional info:
Sounds like someone might have forgotten to add a dependency to the spec file maybe?
Comment 1 Zbigniew Jędrzejewski-Szmek 2017-07-24 08:30:04 EDT

*** This bug has been marked as a duplicate of bug 1461839 ***

Note You need to log in before you can comment on or make changes to this bug.