Bug 1473042 - [3.6] ResourceQuota controller observed making excessive LIST calls at scale
Summary: [3.6] ResourceQuota controller observed making excessive LIST calls at scale
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Derek Carr
QA Contact: Zhang Cheng
URL:
Whiteboard:
Depends On:
Blocks: 1473370
TreeView+ depends on / blocked
 
Reported: 2017-07-19 23:30 UTC by Derek Carr
Modified: 2017-08-16 19:51 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1473370 (view as bug list)
Environment:
Last Closed: 2017-08-10 05:31:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 15357 None None None 2017-07-20 18:28:06 UTC
Red Hat Product Errata RHEA-2017:1716 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.6 RPM Release Advisory 2017-08-10 09:02:50 UTC

Description Derek Carr 2017-07-19 23:30:49 UTC
Description of problem:
For all resources other than Pod or PersistentVolumeClaim, the quota controller is making a LIST call per namespace to determine current usage counts.  This can cause quota recalculation to take an extended period of time.  Secret, ConfigMap, ReplicationControllers, Services, and ResourceQuota quota items should have usage reconciled via a shared informer.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. oc create quota quota --hard=services=10,secrets=10
2.
3.

Actual results:
quota controller should not make LIST calls per namespace when doing recalculation.

Expected results:
quota controller calculates usage from shared informer.

Additional info:
none

Comment 7 errata-xmlrpc 2017-08-10 05:31:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1716


Note You need to log in before you can comment on or make changes to this bug.