Bug 1473068 - incorrect usage of bkr workflow-simple should throw meaningful error
incorrect usage of bkr workflow-simple should throw meaningful error
Status: CLOSED DUPLICATE of bug 1473067
Product: Beaker
Classification: Community
Component: command line (Show other bugs)
develop
Unspecified Unspecified
unspecified Severity low (vote)
: ---
: ---
Assigned To: beaker-dev-list
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-19 21:05 EDT by Anwesha Chatterjee
Modified: 2017-08-11 01:21 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1473067
Environment:
Last Closed: 2017-07-20 23:08:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anwesha Chatterjee 2017-07-19 21:05:19 EDT
+++ This bug was initially created as a clone of Bug #1473067 +++

Description of problem:
The example command in the man page for bkr workflow-simple 
https://beaker-project.org/docs/man/bkr-workflow-simple.html
produces an error 

Version-Release number of selected component (if applicable):
24.3-1.fc25 

How reproducible:
100%

Steps to Reproduce:
1. run bkr workflow-simple

( basically, dont give it any parameters )


Actual results:
XML-RPC fault: <class 'bkr.common.bexceptions.BX'>:Invalid Distro: None

Expected results:
Something more meaningful about what parameters are required

Additional info:
My config for the client is set up for beaker in a box.
Comment 1 Anwesha Chatterjee 2017-07-19 21:16:11 EDT
[Update]
Description of problem:
incorrect usage of the bkr workflow-simple command produces error that isnt meaningful
Comment 2 Anwesha Chatterjee 2017-07-20 23:08:10 EDT

*** This bug has been marked as a duplicate of bug 1473067 ***
Comment 3 Dan Callaghan 2017-07-23 21:22:33 EDT
This doesn't seem like the same problem as bug 1473067, why is it a dupe?
Comment 4 Anwesha Chatterjee 2017-07-24 00:03:17 EDT
Because the code review for bug 1473067 changes the code in this area, I saw that it would be easier to fix the bug described here as it is a pretty minor change - So it isn't a duplicate but is blocked by the previous bug. Which wasnt an option in the dropdown. Should I leave this open, and connect it to the same gerrit review?
Comment 5 Dan Callaghan 2017-08-11 01:21:03 EDT
Okay I getcha. Duping this is fine as long as we note that this is fixed by the other bug's patch:

https://gerrit.beaker-project.org/c/5756

including a test case for the problem described here:

https://gerrit.beaker-project.org/c/5756/10/IntegrationTests/src/bkr/inttest/client/test_workflow_simple.py#28

Note You need to log in before you can comment on or make changes to this bug.