Bug 147309 - mysterious X hang with Radeon 9200 SE and 2.6.10
mysterious X hang with Radeon 9200 SE and 2.6.10
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-06 21:14 EST by Nick Lamb
Modified: 2015-01-04 17:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-02 20:24:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X configuration (2.72 KB, text/plain)
2005-02-07 04:40 EST, Nick Lamb
no flags Details

  None (edit)
Description Nick Lamb 2005-02-06 21:14:10 EST
Description of problem:

When running FC3 kernels 2.6.10 onwards (including recently released
2.6.10-1.760_FC3) the X server is prone to hang or crash in a
distinctive way.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-12.FC3.21
and 2.6.10 kernels as described above

How reproducible:

Happens frequently (once or twice per day) but cannot reproduce
reliably at will :(

Most common symptom is that while selecting text in Mozilla, the
selection is only partly draw (e.g. the top half of a line of text is
highlighted but not the bottom half) and X ceases updating the screen,
except sometimes for the mouse cursor. Keyboard input is seemingly
ignored, num lock + other lights no longer work etc.

A remote connection is usually possible, and neither dmesg nor other
logging show any Ooops, crashlogs, or other symptoms, however X is now
running at ~100% CPU. Attempts to kill the running X server fail, even
kill -9 does not kill the process (remains in state 'R' runnable with
zero'd memory statistics) although the mouse stops working back at
console. Hence, to restore the machine to a usable desktop seems to
require a reboot.

Seeing the problem in 2.6.10 only could be a bizarre coincidence,
although returning to Fedora's last 2.6.9 kernel seemingly sidesteps
the problem indefinitely. Due to other bugs in 2.6.9 I would prefer
not to have to do this (and it bodes ill for running FC4). Could this
be a DRM bug? Was DRM changed in 2.6.10 ?

Video card is a Radeon 9200 SE, and DRI is enabled.
Comment 1 Nick Lamb 2005-02-07 04:40:47 EST
Created attachment 110712 [details]
X configuration

xorg.conf used for the affected machine
Comment 2 Mike A. Harris 2005-02-11 15:36:45 EST
If you've updated the kernel, and haven't changed X at all, and
are now having hangs, it is most probably a kernel flaw rather
than an xorg-x11 flaw.

Reassigning to the kernel component.
Comment 3 Nick Lamb 2005-03-11 21:45:05 EST
So we're now on kernel-2.6.10-1.770_FC3 and I still get the same sort of
problems when I try out these new kernels (they're useless for day-to-day work
so I switch back to 2.6.9 but it's getting silly)

I see a new symptom though, which is a kernel interrupt disabled message,
apparently associated with the radeon DRM module losing interest in IRQ 11 which
is the interrupt associated with the AGP Radeon 9200 SE in this machine. I ask
again, was DRM changed in the 2.6.9 to 2.6.10 update?

If anyone from Red Hat's inevitably over-worked kernel team is going to look at
this what do you need? I can run test kernels, I can provide any diagnostics
that you need, I can even provide a remote login to bona fide Red Hat
developers. You have only to ask...
Comment 4 Dave Jones 2005-07-15 13:55:50 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 5 Dave Jones 2005-10-02 20:24:24 EDT
This bug has been automatically closed as part of a mass update.
It had been in NEEDINFO state since July 2005.
If this bug still exists in current errata kernels, please reopen this bug.

There are a large number of inactive bugs in the database, and this is the only
way to purge them.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.