Bug 1473135 - recipe reviewed state checkboxes should not be available to anonymous users
Summary: recipe reviewed state checkboxes should not be available to anonymous users
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: general   
(Show other bugs)
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: 24.4
Assignee: Anwesha Chatterjee
QA Contact: Dan Callaghan
URL:
Whiteboard:
Keywords: Patch
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-07-20 05:54 UTC by Dan Callaghan
Modified: 2017-10-03 03:57 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-03 03:57:40 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dan Callaghan 2017-07-20 05:54:36 UTC
Version-Release number of selected component (if applicable):
24.3

How reproducible:
easily

Steps to Reproduce:
1. Look at a job page without logging in

Actual results:
Recipe reviewed state checkbox appears for each recipe, and is unchecked.

Expected results:
At first I was confused because I knew I had reviewed all the recipes in this job.
Then I realised I wasn't logged in so Beaker doesn't know who I am.
When the job page is served to an anonymous user, the reviewed state checkbox should be completely omitted (or maybe present but greyed out?).

Comment 1 Anwesha Chatterjee 2017-07-25 03:13:13 UTC
https://gerrit.beaker-project.org/#/c/5758/

Comment 3 Dan Callaghan 2017-09-19 05:21:49 UTC
Verified by logging out, and then going to: https://beaker-devel.app.eng.bos.redhat.com/jobs/12675

Reviewed state checkbox is disabled.

Comment 4 Dan Callaghan 2017-10-03 03:57:40 UTC
Beaker 24.4 has been released.


Note You need to log in before you can comment on or make changes to this bug.