Bug 1473137 - dht: Make throttle option "normal" value uniform across dht_init and dht_reconfigure
dht: Make throttle option "normal" value uniform across dht_init and dht_reco...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
3.10
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Susant Kumar Palai
:
Depends On: 1451162
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-20 02:08 EDT by Susant Kumar Palai
Modified: 2017-08-21 09:41 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.10.5
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1451162
Environment:
Last Closed: 2017-08-21 09:41:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Susant Kumar Palai 2017-07-20 02:08:27 EDT
+++ This bug was initially created as a clone of Bug #1451162 +++

Description of problem:
  Rebalance throttle option "normal" was different across dht_init and dht_reconfigure, which should be same.

This bug will track the fix for it.

--- Additional comment from Worker Ant on 2017-05-16 06:41:26 MVT ---

REVIEW: https://review.gluster.org/17303 (cluster/dht: initialize throttle option "normal" to same in init and reconfigure) posted (#1) for review on master by Susant Palai (spalai@redhat.com)

--- Additional comment from Worker Ant on 2017-05-17 14:02:40 MVT ---

REVIEW: https://review.gluster.org/17303 (cluster/dht: initialize throttle option "normal" to same in init and reconfigure) posted (#2) for review on master by Susant Palai (spalai@redhat.com)

--- Additional comment from Worker Ant on 2017-05-18 08:27:42 MVT ---

COMMIT: https://review.gluster.org/17303 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 2d5da5ae6013d17e5121b1e0bbdf021590533d07
Author: Susant Palai <spalai@redhat.com>
Date:   Tue May 16 07:00:31 2017 +0530

    cluster/dht: initialize throttle option "normal" to same in init and reconfigure
    
    Normal value were different in dht_init and dht_reconfigure.
    Initialization/reconfigure of throttle option are carved out to a separate function
    (dht_configure_throttle) now. Normal value will be "2".
    
    Change-Id: Ie323eae019af41d6bef0a136e3d284dc82bab9a1
    BUG: 1451162
    Signed-off-by: Susant Palai <spalai@redhat.com>
    Reviewed-on: https://review.gluster.org/17303
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Zhou Zhengping <johnzzpcrystal@gmail.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 1 Worker Ant 2017-07-20 02:40:38 EDT
REVIEW: https://review.gluster.org/17836 (cluster/dht: initialize throttle option "normal" to same in init and reconfigure) posted (#1) for review on release-3.10 by Susant Palai (spalai@redhat.com)
Comment 2 Worker Ant 2017-07-20 06:09:59 EDT
REVIEW: https://review.gluster.org/17836 (cluster/dht: initialize throttle option "normal" to same in init and reconfigure) posted (#2) for review on release-3.10 by Susant Palai (spalai@redhat.com)
Comment 3 Worker Ant 2017-08-11 14:06:54 EDT
REVIEW: https://review.gluster.org/17836 (cluster/dht: initialize throttle option "normal" to same in init and reconfigure) posted (#3) for review on release-3.10 by Shyamsundar Ranganathan (srangana@redhat.com)
Comment 4 Worker Ant 2017-08-11 14:37:25 EDT
COMMIT: https://review.gluster.org/17836 committed in release-3.10 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit a5d65b2dc5b8f4801182f53eadaa0edd4fd52a49
Author: Susant Palai <spalai@redhat.com>
Date:   Tue May 16 07:00:31 2017 +0530

    cluster/dht: initialize throttle option "normal" to same in init and reconfigure
    
    Normal value were different in dht_init and dht_reconfigure.
    Initialization/reconfigure of throttle option are carved out to a separate function
    (dht_configure_throttle) now. Normal value will be "2".
    
    > Change-Id: Ie323eae019af41d6bef0a136e3d284dc82bab9a1
    > BUG: 1451162
    > Signed-off-by: Susant Palai <spalai@redhat.com>
    > Reviewed-on: https://review.gluster.org/17303
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > Reviewed-by: Zhou Zhengping <johnzzpcrystal@gmail.com>
    > Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    > Signed-off-by: Susant Palai <spalai@redhat.com>
    
    Change-Id: Ie323eae019af41d6bef0a136e3d284dc82bab9a1
    BUG: 1473137
    Signed-off-by: Susant Palai <spalai@redhat.com>
    Reviewed-on: https://review.gluster.org/17836
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
Comment 5 Shyamsundar 2017-08-21 09:41:22 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.5, please open a new bug report.

glusterfs-3.10.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-August/000079.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.