Bug 1473153 - Need to refresh kibana UI page to show .all index
Need to refresh kibana UI page to show .all index
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity low
: ---
: 3.6.z
Assigned To: Jeff Cantrill
Junqi Zhao
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-20 02:45 EDT by Junqi Zhao
Modified: 2017-10-25 09:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-25 09:04:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Github openshift-elasticsearch-plugin/pull/94 None None None 2017-07-26 14:21 EDT

  None (edit)
Description Junqi Zhao 2017-07-20 02:45:14 EDT
Description of problem:
.all index is not shown on kibana UI page at first logon, if we refresh the page, .all index could be shown on page

Version-Release number of selected component (if applicable):
logging-elasticsearch   v3.6.153-3          f6e798e43e8f        9 hours ago         434.5 MB
logging-kibana          v3.6.153-1          4832b09b1c65        47 hours ago        342.4 MB
logging-fluentd         v3.6.153-1          32879007469a        47 hours ago        231.7 MB
logging-auth-proxy      v3.6.153-1          e79e0601c66b        47 hours ago        214.8 MB
logging-curator         v3.6.153-1          66d7f2b833f2        47 hours ago        221.5 MB

openshift-ansible packages:
openshift-ansible-docs-3.6.153-1.git.0.5a6bf7d.el7.noarch
openshift-ansible-lookup-plugins-3.6.153-1.git.0.5a6bf7d.el7.noarch
openshift-ansible-3.6.153-1.git.0.5a6bf7d.el7.noarch
openshift-ansible-filter-plugins-3.6.153-1.git.0.5a6bf7d.el7.noarch
openshift-ansible-roles-3.6.153-1.git.0.5a6bf7d.el7.noarch
openshift-ansible-callback-plugins-3.6.153-1.git.0.5a6bf7d.el7.noarch
openshift-ansible-playbooks-3.6.153-1.git.0.5a6bf7d.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1.Deploy logging 3.6 via ansible and log in kibana after all the pods become running
2.
3.

Actual results:
.all index is not shown on kibana and kibana ops UI at first logon, need to refresh page to make them shown.

Expected results:
.all index should be shown when log in kibana at the first time.

Additional info:
There is no .all index if use command to check indicies:
curl --key /etc/elasticsearch/secret/admin-key --cert /etc/elasticsearch/secret/admin-cert --cacert /etc/elasticsearch/secret/admin-ca -XGET 'https://localhost:9200/_cat/indices?v'
health status index                                                                pri rep docs.count docs.deleted store.size pri.store.size 
green  open   project.logging.7fdd075a-6cf5-11e7-8ff3-fa163e7fbf71.2017.07.20        1   0        512            0      1.1mb          1.1mb 
green  open   project.java.07159295-6d09-11e7-9c93-fa163e7fbf71.2017.07.20           1   0        266            0    325.6kb        325.6kb 
green  open   .kibana                                                                1   0          1            0      3.1kb          3.1kb 
green  open   project.default.4ac47af3-6cf4-11e7-9b5f-fa163e7fbf71.2017.07.20        1   0        245            0    312.2kb        312.2kb 
green  open   .kibana.ef0b7ff169fdc9202e567ce53aa5e17320cb2d7d                       1   0          5            0     64.4kb         64.4kb 
green  open   .searchguard.logging-es-data-master-s5shfef1                           1   0          5            0     35.4kb         35.4kb 
green  open   project.install-test.dc6d788d-6cf5-11e7-8ff3-fa163e7fbf71.2017.07.20   1   0        228            0    330.3kb        330.3kb
Comment 1 Jeff Cantrill 2017-07-26 14:21:54 EDT
Plugin PR: openshift-elasticsearch-plugin/pull/94
Comment 3 Junqi Zhao 2017-09-14 02:17:18 EDT
.all index could be shown on kibana without refreshing page.

for non-ops cluster, there is log entries under .all index, but for ops enabled cluster, there is not log entries under .all index, there is one defect for this issue: https://bugzilla.redhat.com/show_bug.cgi?id=1490719.

Close this defect 

# openshift version
openshift v3.6.173.0.32
kubernetes v1.6.1+5115d708d7
etcd 3.2.1


Images
logging-kibana:v3.6.173.0.33-1
logging-elasticsearch:v3.6.173.0.33-1
logging-auth-proxy:v3.6.173.0.33-1
logging-fluentd:v3.6.173.0.33-1
logging-curator:v3.6.173.0.33-1
Comment 6 errata-xmlrpc 2017-10-25 09:04:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3049

Note You need to log in before you can comment on or make changes to this bug.