Bug 1473169 - [v2v] Failures/Errors are not reflected at all in the Automate request messages
[v2v] Failures/Errors are not reflected at all in the Automate request messages
Status: CLOSED CURRENTRELEASE
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.8.0
Unspecified Unspecified
high Severity high
: GA
: 5.9.0
Assigned To: Tomas Jelinek
Ilanit Stein
rhev:v2v
: TestOnly, ZStream
Depends On:
Blocks: 1479414
  Show dependency treegraph
 
Reported: 2017-07-20 03:37 EDT by Ilanit Stein
Modified: 2018-03-06 09:46 EST (History)
7 users (show)

See Also:
Fixed In Version: 5.9.0.1
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1479414 (view as bug list)
Environment:
Last Closed: 2018-03-06 09:46:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: RHEVM


Attachments (Terms of Use)
vdsm.log (583.52 KB, application/x-xz)
2017-07-20 03:42 EDT, Ilanit Stein
no flags Details
import log (104.37 KB, text/plain)
2017-07-20 03:43 EDT, Ilanit Stein
no flags Details

  None (edit)
Description Ilanit Stein 2017-07-20 03:37:10 EDT
Description of problem:
When there are failures in the import of VM, from VMWare to RHV, It is not reflected in the CFME Automate->Request. 
The Request last message keeps having Message [Checking for VM Import completion] Current Retry Number [...].

Examples:
1. When running v2v for a Windows VM that has snapshots, which is not possible.
On vdsm.log, this error is seen:
"2017-07-19 15:31:22,081+0300 ERROR (jsonrpc/7) [root] vm 'win7_auto' has snapshots and therefore can not be imported since snapshot conversion is not supported for VMware (v2v:176)"
(See vdsm.log attached)

2. When v2v fail for a Windows VM on the following error (taken from v2v import log):
"virt-v2v: error: unable to mount the disk image for writing. This has
probably happened because Windows Hibernation or Fast Restart is being used
in this guest. You have to disable this (in the guest) in order to use
virt-v2v."
(See import log attached)

Source VM name: "win10_IDE"


** Indeed those errors are not seen in the engine.log, but in engine.log,
it is mentioned that the import/convert failed, and even that is not propagated to CFME.

Version-Release number of selected component (if applicable):
CFME-5.8.1 + several fixes for v2v bugs/RHV-4.1
Comment 2 Ilanit Stein 2017-07-20 03:42 EDT
Created attachment 1301555 [details]
vdsm.log
Comment 3 Ilanit Stein 2017-07-20 03:43 EDT
Created attachment 1301557 [details]
import log
Comment 6 Ilanit Stein 2018-01-02 02:37:12 EST
Verified on CFME-5.9.0.14/RHV-4.1.8,
that the message in the request indicate import failed:

* When destination VM name already exist (Seen in engine.log):
[EVM] VM [mb-win10] Step [Launch] Status [Error submitting VM Import to RHV] Message [Submitting VM Import to RHV]

* When windows VM import failed on mount problem (seen in the host vdsm/import log):
[EVM] VM [tg-win10] Step [WaitForImport] Status [Error encountered during VM import] Message [Checking for VM Import completion]

Note You need to log in before you can comment on or make changes to this bug.