Bug 147321 - named starts too late for programs that need DNS
named starts too late for programs that need DNS
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: caching-nameserver (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-07 04:57 EST by Evan Champion
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-04 19:54:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Evan Champion 2005-02-07 04:57:49 EST
I installed caching-nameserver and made 127.0.0.1 my only nameserver
in /etc/resolv.conf.  Tastes great, and works much better than nscd
which doesn't work for my configuration (it does not work properly
with compat NIS notation, food for another ticket).

However, I have since had problems with some other startup scripts
(i.e. ypbind) that use nameservice.  named starts too late (S55named),
and without another nameserver configured, things don't work very well.

My assumption is that nameservice is a critical network service that
should be available as soon as the network comes up, so I moved it to
the space available at S11named.  Since then everything starts up great.
Comment 1 Jason Vas Dias 2005-02-07 10:51:07 EST
Whether named is installed at any runlevel has always been up to the
administrator - they must do something like:
  # chkconfig --level=345 named on
  # chkconfig --level=0126 named off
because the chkconfig line in /etc/init.d/named has always been:
  
# chkconfig: - 55 45
# 

Meaning that named is not "on" by default in any run level, and is
started with order 55, and stopped with order 45.

As you point out, many services that require a name service are 
started before named by default, so the '55 45' positions are
not good as defaults .

In the next version of named, I will make the chkconfig line:
  
# chkconfig: - 11 89

so it should get started / stopped directly after / before 
the 'network' service .

The traditional behaviour of not being run in any runlevel by
default will be preserved.


Comment 2 Jason Vas Dias 2005-02-25 15:03:12 EST
This is now fixed in bind-9.2.5rc1-1 (FC3) / bind-9.3.1rc1-1 (FC4).


Note You need to log in before you can comment on or make changes to this bug.