Bug 1473248 - jose jwk gen segfaults on invalid data
jose jwk gen segfaults on invalid data
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: jose (Show other bugs)
7.4
All Linux
unspecified Severity high
: rc
: ---
Assigned To: Nathaniel McCallum
Jiri Jaburek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-20 06:09 EDT by Miroslav Vadkerti
Modified: 2018-04-10 10:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 10:41:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0819 None None None 2018-04-10 10:41 EDT

  None (edit)
Description Miroslav Vadkerti 2017-07-20 06:09:51 EDT
Description of problem:

# jose jwk gen -i 'test' -o $DB/new_sig.jwk
Segmentation fault

Version-Release number of selected component (if applicable):
jose-8-1.el7

How reproducible:
100%

Steps to Reproduce:
1. $ jose jwk gen -i 'test' -o $DB/new_sig.jwk

Actual results:
Segfault

Expected results:
No segfault, error that invalid JSON input was passed via -i option

Additional info:
Comment 3 Nathaniel McCallum 2017-09-29 14:23:15 EDT
Fixed in jose-10-1.el7.
Comment 9 errata-xmlrpc 2018-04-10 10:41:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0819

Note You need to log in before you can comment on or make changes to this bug.