Bug 1473316 - [HA] TripleO should support Node replacement of OpenDaylight controller
[HA] TripleO should support Node replacement of OpenDaylight controller
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-tripleo (Show other bugs)
12.0 (Pike)
Unspecified Unspecified
high Severity high
: ga
: 12.0 (Pike)
Assigned To: Janki
Itzik Brown
: TestOnly, Triaged
Depends On:
Blocks: 1414313
  Show dependency treegraph
 
Reported: 2017-07-20 09:11 EDT by Itzik Brown
Modified: 2018-02-05 14:10 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-13 16:43:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Itzik Brown 2017-07-20 09:11:11 EDT
Description of problem:
There is a procedure to replace an OpenStack controller node but not one for 
OpenDaylight controller.
TripleO should support this case.

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-7.0.0-0.20170706121722.el7ost.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Nir Yechiel 2017-07-20 14:04:05 EDT
Itzik, have you discussed this with Tim? Is there an upstream bug for this?
Comment 2 Itzik Brown 2017-07-23 03:35:07 EDT
No,I'll discuss it with him.
Comment 10 Tim Rozet 2017-08-18 12:18:00 EDT
After reading the instructions I believe that this method with OpenDaylight as a service on the controller should just work.  ODL is not managed by pacemaker and does not rely on the other services that require manual intervention.  The puppet-opendaylight module should fix the config files to use the new node as part of the cluster and restart all ODLs during the update.  That means there is likely < 5 min of downtime for ODL during the operation, but dataplane should remain up.
Comment 22 errata-xmlrpc 2017-12-13 16:43:17 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462

Note You need to log in before you can comment on or make changes to this bug.