Bug 1473340 - WebUI do not display correctly amount of RAM for VMs with more than 64G
WebUI do not display correctly amount of RAM for VMs with more than 64G
Status: CLOSED DUPLICATE of bug 1270771
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Compute Resources - RHEV (Show other bugs)
6.2.10
x86_64 Linux
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-20 10:23 EDT by Vladimir Vasilev
Modified: 2017-07-20 10:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-20 10:45:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Vasilev 2017-07-20 10:23:32 EDT
Description of problem:
I'm not sure if this should go as RFE, I'll leave this to you.

I cannot provision new VM with RHEV as compute resource with more than 64GB of RAM. The field for RAM is dropdown and I cannot specify anything outside the list. Also if I change later directly in RHEV the amount of RAM in Satellite it's displaying 256MB

Version-Release number of selected component (if applicable):
6.2.10

How reproducible:
100%

Steps to Reproduce:
1. Create VM with 1GB of RAM in RHEV compute resource
2. After it's provisioned power it off and set RAM directly in RHEV to more than 64GB
3.Edit any field of the VM in satellite (for example parameter).


Actual results:
Error related to RAM. I cannot give now the exact error because it's a production system.

Expected results:
New settings applied.

Additional info:
Two problems are actually here. If you want I can do additional BZ.
If a VM has more than 64G RAM set in RHEV then in Satellite it displays it as 256MB in Virtual Machine tab. This breaks saving anything because it will try to set 256MB RAM when you submit.
The other problem is that you cannot provision a VM initially with more than 64G RAM due to hardcoded values.
Comment 1 Marek Hulan 2017-07-20 10:45:05 EDT
Thanks for the report, I believe this has been already reported as BZ 1270771. Also please don't use WebUI for bugs found in specific areas. It's for generic WebUI issues like "font too small", "all links should have different color". Moving to Compute Resource - RHEV.

Closing as duplicate, please reopen if I misunderstood the request. Thanks for searching existing BZs before opening new ones.

*** This bug has been marked as a duplicate of bug 1270771 ***

Note You need to log in before you can comment on or make changes to this bug.