Bug 1473350 - AttributeError: 'ResizeDialog' object has no attribute 'size_chooser'
AttributeError: 'ResizeDialog' object has no attribute 'size_chooser'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: blivet-gui (Show other bugs)
26
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vojtech Trefny
Fedora Extras Quality Assurance
abrt_hash:f5327dee566a635412e463175c5...
:
: 1482224 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-20 11:03 EDT by Mustafa Mahmood
Modified: 2017-08-22 16:44 EDT (History)
9 users (show)

See Also:
Fixed In Version: blivet-gui-2.1.6-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-22 16:44:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (3.68 MB, text/plain)
2017-07-20 11:03 EDT, Mustafa Mahmood
no flags Details
File: anaconda.log (108.33 KB, text/plain)
2017-07-20 11:03 EDT, Mustafa Mahmood
no flags Details
File: environ (591 bytes, text/plain)
2017-07-20 11:03 EDT, Mustafa Mahmood
no flags Details
File: journalctl (1.07 MB, text/plain)
2017-07-20 11:03 EDT, Mustafa Mahmood
no flags Details
File: lsblk_output (3.19 KB, text/plain)
2017-07-20 11:04 EDT, Mustafa Mahmood
no flags Details
File: lvm.log (1.12 MB, text/plain)
2017-07-20 11:04 EDT, Mustafa Mahmood
no flags Details
File: nmcli_dev_list (2.11 KB, text/plain)
2017-07-20 11:04 EDT, Mustafa Mahmood
no flags Details
File: os_info (518 bytes, text/plain)
2017-07-20 11:04 EDT, Mustafa Mahmood
no flags Details
File: program.log (267.59 KB, text/plain)
2017-07-20 11:04 EDT, Mustafa Mahmood
no flags Details
File: storage.log (1004.71 KB, text/plain)
2017-07-20 11:04 EDT, Mustafa Mahmood
no flags Details
File: ifcfg.log (8.81 KB, text/plain)
2017-07-20 11:04 EDT, Mustafa Mahmood
no flags Details

  None (edit)
Description Mustafa Mahmood 2017-07-20 11:03:31 EDT
Description of problem:
Try to resize my root partition or home partition.
every time I do this using the advanced (BLIVET GUI PARTITIONING) the crash happen and exit the installation.

Version-Release number of selected component:
anaconda-core-26.21.11-1.fc26.x86_64

The following was filed automatically by anaconda:
anaconda 26.21.11-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.6/site-packages/blivetgui/dialogs/edit_dialog.py", line 102, in run
    selected_size = self.size_chooser.get_selection()
  File "/usr/lib/python3.6/site-packages/blivetgui/osinstall.py", line 215, in run_dialog
    response = dialog.run()
  File "/usr/lib/python3.6/site-packages/blivetgui/blivetgui.py", line 267, in resize_device
    user_input = self.run_dialog(dialog)
AttributeError: 'ResizeDialog' object has no attribute 'size_chooser'

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/libexec/system-python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz root=live:CDLABEL=Fedora-WS-Live-26-1-5 rd.live.image rd.live.check quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.11.8-300.fc26.x86_64
other involved packages: blivet-gui-runtime-2.1.5-2.fc26.noarch
product:        Fedora
release:        Fedora release 26 (Twenty Six)
type:           anaconda
version:        26
Comment 1 Mustafa Mahmood 2017-07-20 11:03:48 EDT
Created attachment 1301780 [details]
File: anaconda-tb
Comment 2 Mustafa Mahmood 2017-07-20 11:03:52 EDT
Created attachment 1301781 [details]
File: anaconda.log
Comment 3 Mustafa Mahmood 2017-07-20 11:03:54 EDT
Created attachment 1301782 [details]
File: environ
Comment 4 Mustafa Mahmood 2017-07-20 11:03:59 EDT
Created attachment 1301783 [details]
File: journalctl
Comment 5 Mustafa Mahmood 2017-07-20 11:04:01 EDT
Created attachment 1301784 [details]
File: lsblk_output
Comment 6 Mustafa Mahmood 2017-07-20 11:04:07 EDT
Created attachment 1301785 [details]
File: lvm.log
Comment 7 Mustafa Mahmood 2017-07-20 11:04:08 EDT
Created attachment 1301786 [details]
File: nmcli_dev_list
Comment 8 Mustafa Mahmood 2017-07-20 11:04:10 EDT
Created attachment 1301787 [details]
File: os_info
Comment 9 Mustafa Mahmood 2017-07-20 11:04:14 EDT
Created attachment 1301788 [details]
File: program.log
Comment 10 Mustafa Mahmood 2017-07-20 11:04:19 EDT
Created attachment 1301789 [details]
File: storage.log
Comment 11 Mustafa Mahmood 2017-07-20 11:04:22 EDT
Created attachment 1301790 [details]
File: ifcfg.log
Comment 12 Sergi Serra 2017-07-23 17:28:09 EDT
Similar problem has been detected:

I was trying to resize the fedora-root directory in a LVM volume.

addons:         com_redhat_kdump, com_redhat_docker
cmdline:        /usr/libexec/system-python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora-WS-dvd-x86_64-26 rd.live.check quiet
hashmarkername: anaconda
kernel:         4.11.8-300.fc26.x86_64
package:        anaconda-26.21.11-1
product:        Fedora
reason:         AttributeError: 'ResizeDialog' object has no attribute 'size_chooser'
release:        Cannot get release name.
version:        26
Comment 13 Vojtech Trefny 2017-08-17 02:12:20 EDT
*** Bug 1482224 has been marked as a duplicate of this bug. ***
Comment 14 Fedora Update System 2017-08-18 07:22:21 EDT
blivet-gui-2.1.6-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d89c6ec068
Comment 15 Fedora Update System 2017-08-19 14:56:06 EDT
blivet-gui-2.1.6-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d89c6ec068
Comment 16 Fedora Update System 2017-08-22 16:44:44 EDT
blivet-gui-2.1.6-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.