Bug 1473400 - [RFE]: rgw: nfs-ganesha store exports in RADOS
[RFE]: rgw: nfs-ganesha store exports in RADOS
Status: CLOSED ERRATA
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW (Show other bugs)
3.0
All All
low Severity urgent
: rc
: 3.0
Assigned To: Matt Benjamin (redhat)
ceph-qe-bugs
: CodeChange, FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-20 13:28 EDT by Matt Benjamin (redhat)
Modified: 2017-12-05 18:38 EST (History)
13 users (show)

See Also:
Fixed In Version: RHEL: nfs-ganesha-2.5.2-2.el7cp Ubuntu: nfs-ganesha_2.5.2-3redhat1xenial
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-05 18:38:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Benjamin (redhat) 2017-07-20 13:28:57 EDT
Currently nfs-ganesha instances persistently recover filesystem exports from local files only.

The change will enable exports to be recovered from RADOS for the benefit of openstack manila integration.
Comment 4 Drew Harris 2017-08-30 11:22:40 EDT
This is required OSP 13 manilla support. Does not need to be tested for 3.0 GA.
Comment 5 Daniel Gryniewicz 2017-09-05 13:40:07 EDT
This is in Ganesha next as of 2 weeks ago:

commit f7a09d87851f64a68c2438fdc09372703bcbebec
Author:     Matt Benjamin <mbenjamin@redhat.com>
AuthorDate: Thu Jul 20 15:21:00 2017 -0400
Commit:     Frank S. Filz <ffilzlnx@mindspring.com>
CommitDate: Thu Aug 17 14:46:29 2017 -0700

    config: add config_url and RADOS url provider
    
    Provides a mechanism to to load nfs-ganesha config sections (e.g.,
    export blocks) from a generic URL.  Includes a URL provider
    which maps URLs to Ceph RADOS objects.
    
    Change-Id: I9067eaef2b38a78e9f1a877dfb9eb3c176239e71
    Signed-off-by: Matt Benjamin <mbenjamin@redhat.com>
Comment 8 Daniel Gryniewicz 2017-09-07 08:28:16 EDT
This cherry-picks cleanly on top of the commits listed in bug #1473399
Comment 18 errata-xmlrpc 2017-12-05 18:38:03 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3387

Note You need to log in before you can comment on or make changes to this bug.