Bug 1473405 - Truncated S3 objects
Summary: Truncated S3 objects
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.3
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 3.0
Assignee: Orit Wasserman
QA Contact: vidushi
Bara Ancincova
URL:
Whiteboard:
Depends On:
Blocks: 1494421
TreeView+ depends on / blocked
 
Reported: 2017-07-20 17:50 UTC by Orit Wasserman
Modified: 2017-12-05 23:38 UTC (History)
8 users (show)

Fixed In Version: RHEL: ceph-12.1.2-1.el7cp Ubuntu: ceph_12.1.2-2redhat1xenial
Doc Type: Bug Fix
Doc Text:
.Large objects are no longer truncated When creating large objects on large clusters, some of the objects were truncated at 512 KB size. Consequently, an attempt to read such objects failed with `Error 404`. This bug has been fixed, and large objects are no longer truncated. As a result, reading such objects works as expected.
Clone Of:
Environment:
Last Closed: 2017-12-05 23:38:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 20107 None None None 2017-07-20 17:50:43 UTC
Red Hat Product Errata RHBA-2017:3387 normal SHIPPED_LIVE Red Hat Ceph Storage 3.0 bug fix and enhancement update 2017-12-06 03:03:45 UTC

Description Orit Wasserman 2017-07-20 17:50:44 UTC
Description of problem:
On a large cluster, we are seeing some objects being truncated at 512kb size

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a large object
2. Try to read the object


Actual results:
Error 404

Expected results:
Get the object

Additional info:

Comment 11 errata-xmlrpc 2017-12-05 23:38:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3387


Note You need to log in before you can comment on or make changes to this bug.