Bug 147341 - RHN reports blank epoch as out of date
RHN reports blank epoch as out of date
Status: CLOSED DUPLICATE of bug 235244
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
RHN Stable
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-07 10:06 EST by Josh Kelley
Modified: 2007-04-24 14:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-24 14:19:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Josh Kelley 2005-02-07 10:06:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
It's my understanding that a missing epoch is equivalent to an epoch
number of 0.  For example, up2date will recognize a package with no
epoch as a possible upgrade for a package with an epoch of 0. 
However, the RHN web site says that a package with no epoch is
outdated by a package with an epoch of 0.

For example, samba-3.0.11-1 (no epoch) is considered as being in the
same epoch as samba-3.0.9-1.3E.2:0, so it should be considered an
upgrade to samba-3.0.9-1.3E.2:0.  up2date recognizes samba-3.0.11-1 as
an upgrade to samba-3.0.9-1.3E.2:0, but the RHN web site says that a
host with samba-3.0.11-1 installed is out of date.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install samba-3.0.11-1 from Samba's web site.
2. Run up2date -p.
3. Go to the RHN web site.
    

Actual Results:  RHN says that the host is out of date and should have
samba-3.0.9-1.3E2:0 installed.

Expected Results:  RHN should recognize that the host is up to date.

Additional info:
Comment 1 Matthew Davis 2007-04-24 14:19:14 EDT

*** This bug has been marked as a duplicate of 235244 ***

Note You need to log in before you can comment on or make changes to this bug.