Bug 1473437 - empty Astloch.ttf
empty Astloch.ttf
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: astloch-fonts (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Julien Enselme
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-20 16:37 EDT by Hin-Tak Leung
Modified: 2017-08-02 12:49 EDT (History)
1 user (show)

See Also:
Fixed In Version: astloch-fonts-1.00-7.41528389c445hg.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-02 12:49:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hin-Tak Leung 2017-07-20 16:37:17 EDT
Description of problem:
I wonder why nobody noticed:

rpm -V astloch-fonts # success

$ ls -l /usr/share/fonts/astloch/
total 76
-rw-r--r--. 1 root root 75684 Feb 10 06:31 Astloch-Bold.ttf
-rw-r--r--. 1 root root     0 Feb 10 06:31 Astloch.ttf

Version-Release number of selected component (if applicable):
astloch-fonts-1.00-6.41528389c445hg.fc26.noarch

How reproducible:
Always

Steps to Reproduce:
1. N/A
2.
3.

Actual results:
empty font file

Expected results:
non-empty, or not shipping it.

Additional info:

Was running the latest dev code of Font Validator against all 3283 fonts shipped by fedora 26, before releasing v2.1, and notices that this font has a very small report size.
http://github.com/HinTak/Font-Validator
Comment 1 Fedora Update System 2017-07-23 07:44:10 EDT
astloch-fonts-1.00-7.41528389c445hg.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-6d9a994363
Comment 2 Julien Enselme 2017-07-23 07:45:40 EDT
No idea what happened. From what I see, the problem was introduced during the mass rebuild for f26. Just pushed an updated that will fix this.

Thank you for spotting and reporting this.
Comment 3 Fedora Update System 2017-07-25 00:24:37 EDT
astloch-fonts-1.00-7.41528389c445hg.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-6d9a994363
Comment 4 Fedora Update System 2017-08-02 12:49:24 EDT
astloch-fonts-1.00-7.41528389c445hg.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.